Netrunner Home

[Realtek rtl8723be - wifi problem]


#1

Hi,
for many reasons i need to install some linux distro on my laptop, (hp pavillon gaming 15-ak112nl);
i tried with xubuntu 17.04 and my wi-fi didn’t work at all; so i followed many guides about the configuration of my realtek rtl8723be, but i failed.

So i found somewhere (cannot recover where) someone who said that netrunner require some configuration as xubuntu, but can actually works with my network card.

I launched the netrunner live and wi-fi can recognize two networks with the minimum power (1/5), but it can’t recognize my home network at all.

With windows 10 i have 4/5.

On another laptop i have xubuntu 16.04 with a realtek rtl8101/2/6E, and works fine (2-3/5. that is enough).

Is there someone who tried netrunner on this kind of network card, or at least can guide me on the configuration of the network card (kernel, driver, ecc ecc)?

If you need some report from konsole, just ask for it.

Thank you,
LM


#2

If I am not completely mistaken the rtl8723be is a very problematic chip. It usually has two antennas though only one can be used with the linux driver and in your case that seems to be the weaker one.
But even if you have a connection it often interrupts.

Newer kernels might help.
I ended up throwing this card out and buying an Atheros AR9565 which uses the ath9k and works flawlessly.


#3

It’s not that only one antenna can be used, it’s that some manufacturers that only installed one antenna wire also had an incorrectly encoded EFUSE.

To make a long story short, when only one antenna wire was connected:
In kernel 4.14 ant_sel=1 could be used in a custom /etc/modprobe.d/rtl8723be.conf file to get a better signal strength.
In kernel 4.15 this was reversed in the code so ant_sel=2 had to be used.
In kernel 4.16 something happened in the code that caused neither to work.
Note: This has since been corrected in kernel 4.16.8 with an interim patch. This patch is also to be back-ported into all current stable kernels.

Here is the bug report: https://bugzilla.kernel.org/show_bug.cgi?id=83641#c21
Here is the commit that fixes it: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/?h=v4.16.8&id=709c26e9c81f4c600df7ec0d5749a90a87dc5081

Another option would be to buy a second antenna wire and install it oneself, then all these problems go away.
However, this would also in most cases void the warranty.