Netrunner Home

Recent System Update


#1

[quote]
This system has a graphics card which is no longer handled by the NVIDIA driver
(package nvidia-driver). You may wish to keep the package installed - for
instance to drive some other card - but the card with the following chipset
won’t be usable:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT
630] [10de:0f00] (rev a1)

The above card requires either the non-free legacy NVIDIA driver (package
nvidia-legacy-390xx-driver) or the free Nouveau driver (package
xserver-xorg-video-nouveau).

Use the update-glx command to switch between different installed drivers.

Before the Nouveau driver can be used you must remove NVIDIA configuration from
xorg.conf (and xorg.conf.d/).

Install NVIDIA driver despite unsupported graphics card? [yes/no]
[unquote]

I somehow fouled up the latest update. After rebooting, the system stopped at TTY session.
Subsequently to purging nvidia from the system, I was able to install xserver-xorg-video-nouveau.

I was trying installing a suitable nvidia-driver via https://packages.debian.org/sid/nvidia-driver but am afraid that all this is out of my depth and request assistance for installing the correct nvidia driver to Netrunner 19.01, thanks.


#2

I think just installing the nvidia-driver package should be enough. Your card is very new and the 410 driver should support this card. If that isn’t the case you might really need to directly grab the driver from nvidias site (418 atm) and install this one according to the instructions provided by nvidia.


#3

But the cautionary note generated by the Update Manager seems to suggest otherwise. Am I misinterpreting the written text? Or did the Update Manager recognize the validity of my card?


#4

I assume that the message is thrown because the card is too new actually. Otherwise Nvidia.com wants me to install 418 of the nvidia driver version. So try it with the nvidia-driver from debian. If it isn’t working remove that driver and then install the nvidia driver from the nvidia website according to their howto.


#5

Oh boy, all this is mindboggling…

I purposely unmarked the Levels 4 & 5 in mint-update hoping to avoid complications during the update processes. Alas, my Laptop became completely unusable but was able to recover the system in my Desktop computer.

  1. Even though the graphic card(s) is/are current & valid the message shown during the recent update is difficult to understand.

  2. Because of this occurrence I am reluctant to use sudo apt install nvidia-driver as am concerned the (menacing) ‘message’ may appear during future updates…

  3. A search for driver version 418 on Nvidia.com produced the following comment:

“You have searched for packages that names contain 418 atm in suite(s) sid, all sections, and architecture(s) amd64.
Sorry, your search gave no results.”

  1. However, I was able to download NVIDIA-Linux-x86_64-340.107.run from https://www.geforce.com/drivers

I searched for an appropriate installation procedure but am unsure on how to go forward; Would you please provide a correct command for installing this driver, thanks.

FYI: The /etc/apt/sources.list indicates: # deb http://deb.netrunner.com/dci/packages/debian/netrunner-1901/ testing non-free contrib main


#6

If you are unsure create a backup before. However this is the easiest to try out and to repair if it does not work for you.

Please use the driver center by nvidia and select your card and linux as plattform to get the newest driver for your card.
Of course you could also use this link to get the driver directly if necessary:
https://www.nvidia.com/object/unix.html

That might be too old for your new card.

Every driver download page has an additional information tab with a link to a readme. Like this one:
http://us.download.nvidia.com/XFree86/Linux-x86_64/418.43/README/index.html

Like said initially I recommend trying installing the nvidia-driver package first before trying anything else.


#7

Because of my limited technical skills I really don’t want to do or try anything ‘adventurous’ to my installed operating system but am backing up my important files conscientiously.

I used your suggested method for installing the nvidia driver on Feb 20 which worked smoothly until the recent update.

In my considered view and based on my current graphic card, one should not expect a cautionary message only because the card is too new which creates havoc to the mind of the non-tech user and when following the suggested prompts causes the computer to become inoperable.

The additional links to various documents are no doubt most valuable for the knowledgeable computer enthusiast but present too much information and confusion to users like myself.

I again will install the driver using the command sudo apt install nvidia-driver and hope the next system update will go trouble-free.

PS: I like KDE and am missing Maui very much!


#8

You are absolutely right. I am not sure what happened here. The driver and warning message comes from Debian.
So for now just ignore the warning.


#9

The warning message appeared during the general update process; There was no way during which particulate update item this message would pop-up.

Anyway, I ‘answered’ yes on my laptop computer - this action made it unusable. Admittedly, limitations of my technical abilities was probably a contributing factor in the failure of the operating system.

However, I ‘answered’ no on my desktop computer - this action made it partly unusable and was able to recover from the (presumingly) graphic card glitch while on tty mode.

Let’s hope Debian have recognized and fixed this issue. With this in mind one could mark this post as ‘guardedly’ solved.