back to Netrunner | back to Blue Systems

Redshift-Plasmoid Scroll Wheel functionality is bugged


#1

Hi all, decided to try out Netrunner (the standard Debian version) for the first time in years, and so far am very impressed.

I’ve only encountered a few problems in my testing.

  1. The Redshift-Plasmoid usually allows the user to manually adjust the brightness and hue via hovering the mouse cursor over the icon in the taskbar, and scrolling with the scroll wheel up and down.

However, in Netrunner the scroll wheel will only adjust the brightness and hue 1 way (I.E, scrolling up will also decrease brightness just like scrolling down does, where as the normal behavior on other distros is to increase brightness).

On my laptop (Intel GPU) running NeptuneOS, the Plasmoid functions normally. This behavior only seems to occur with Netrunner (which I happen to be testing on a desktop with Nvidia graphics, both on Nouveu and proprietary driver).

  1. With the default Netrunner dark theme, as well as other dark theme’s I’ve tried, the properties window of a sound or microphone device is only half readable due to the bright text on the white background.

To get to the window in question:

left click sound icon on taskbar > right click device icon > select properties

  1. Turning off the Title Bar in the ‘Customize’ section of Firefox’s settings does not remove the KDE title bar, instead it adds window controls to the Firefox bar in addition to KDE’s own Titlebar. On NeptuneOS, this toggle worked correctly, and removed the KDE Titlebar, saving screen space.

Just thought I’d make this post to see if there’s something I might be doing wrong, or to raise awareness of these issues if they haven’t been reported before.

Thank you for your time. :slight_smile:

(P.S. If it’d be helpful, I can create individual posts of the other 2 bugs here. I only bundled them for convenience sake. :P)


#2
  1. might have something to do that we ship a “hack” that adds titlebars to GTK windows (as they use client side decoration usually).
    In any way you could manually set a rule for firefox to hide the titlebar completely if you want to. Just right click on the titlebar and select advanced. Here you can set special options for this window or application.

  2. Very strange. It should behave the same if it is the same version of the plasmoid.

  3. That might be a bug in the theming or the applications not dealing correctly with darkish themes. We will take a look into it. Otherwise changing the theme to something brighter might help here.


#3

Cheers for the response!

Since making this thread, I tried another Debian based KDE distro, Q4OS, which exhibits the same Redshift Plasmoid bug on the PC with the Nvidia GPU, so it’s not a Netrunner specific bug as I had originally thought.

Thanks for the titlebar suggestion (never knew KDE could do that!), I’ll definitely give that a try when I can.

Hope you have a great day, Leszek. :slight_smile:


#4

I had the same problem. It’s the latest redshift that’s at fault. Uninstalling it and installing the previous version fixed the problem for me. Redshift 1.11-1 and Plasmoid controller 1.0.17-1 work correctly. 1.12 & 1.0.18 do not.