Replacing SDDM witch Lightdm

Hello everybody.

I got some problems when i tried to install LightDM to my netrunner installation. When I tried to install the lightdm packages i got the following message (original error msg is in German so i give a rough translation):

lightdm and sddm are in conflict (displamanager), remove sddm?

When I try to remove sddm I get a message telling me that several packages depend on the package sddm, among them the package netrunnerarch-default-settings. After a short look into the purpose of that package (it contains the default configuration for several kde applications) I didn’t dare to go any further :).

Does anyone have any idea what i can do to get LightDM on my system? Do i overestimate the importance of the package netrunnerarch-default-settings? Or do I have to open an error report and ask the developers to remove the dependency of a central component to SDDM ?

Thanks in advance for any helpful comments

Did you try this in the terminal with pacman or from within Octopi?

I used pacman for all the commands.

SDDM is replacing KDM and will be the default for Plasma 5 once it becomes our default desktop as the lock screen needs it to work properly, just a FYI.

Anyway, this is a problem in Netrunner Rolling at the moment, the Netrunner development team need to work on their netrunner specific packages so they don’t conflict with the way a Rolling Release model is supposed to work.

OK, now to actually be helpful.

First you’ll need to stop and disable SDDM:

sudo systemctl stop sddm.service sudo systemctl disable sddm.service

Then to remove SDDM you may need to use the no dependencies switches in pacman like this:

 sudo pacman -Rdd sddm

Now you can install and enable lightDM.
However since LightDM takes a bit more work to get set up than SDDM, you will need to refer to the Manjaro wiki for this part:

PS. You may also need to ask the Netrunner team for their Netrunner LighDM theme as well:

Thanks for your help AJSlye, it worked quite well.

Just for documentation purpose I did the following:

pacman -Rdd sddm kcm-sddm-git sddm-archlinux-theme-git sddm-futuristic-theme sddm-menda-theme sddm-numix-theme-git

pacman -S community/lightdm community/lightdm-webkit-greeter community/lightdm-webkit-theme-bevel community/lightdm-webkit-theme-manjaro-light accountsservice

Then i used this page from the manjaro wiki to configure lightdm:
Attention: The entries for the lighdm.conf file as described in that page contain a nasty little bug. If you enter the comments as given in the example, lightdm will add some space characters to the filename it searches for further configuration, resulting in a “config file not found error”. I simply dropped the comments and everything worked right.
I set the user-session parameter to “kde-plasma”.

If anyone else as crazy as me wants to do the same, that might be helpful.

You shouldn’t have had all of those themes installed.
Did you happen to install those extra themes yourself at some point?
Never mind, it doesn’t mater as long as it worked. :slight_smile:

Also If you don’t mind, could you please post the issue you experienced with the Wiki page example and how you fixed it in in the Manjaro?

I’m not sure if I installed all the sddm themes by hand. Sorry can’t remember.

Yep I’ll have a look where at the manjaro wiki i can report the error.

Thanks again

Not in the wiki, post it in the forum under Technical Issues and Assistance > Applications & Desktop Environments here: