Repositories/ Source List Problem

I know this issue has been covered a few times before but nothing recommended in previous threads appears to work for the problem I seem to have. I am a complete newbie, so you have to explain it in ABC language…!

Somehow the additional-repositories source.list has become corrupted and I cannot get access to edit the contents.

The error I get in Muon Discover is:
The package system could not be initialized, your configuration may be broken.

Type ‘http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages’ is not known on line 2 in source list /etc/apt/sources.list.d/additional-repositories.list

and in Synaptics Package Manager it is:

E: Type ‘http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages’ is not known on line 2 in source list /etc/apt/sources.list.d/additional-repositories.list
E: The list of sources could not be read.
Go to the repository dialogue to correct the problem.
E: _cache->open() failed, please report.

The additional-repositories list says this:
deb http://packages.netrunner-os.com frontier-14 main #id:netrunner_main
http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages
http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages

But these repositories do not show up on Software Sources to enable them to be edited. I think the last 2 are missing the ‘deb’ and deb-src or may be shouldn’t even be there. What can I do? http://forums.netrunner-os.com/images/smilies/sad.gif

Yeah those lines are missing the deb in front and the deb-src.
We ship the ubuntu-wine ppa enabled by default. I am not sure why it is added this way in your repositories list.
See the original files here: https://github.com/netrunner/netrunner-apt-config/tree/master/etc/apt/sources.list.d

Cheers Leszek!
How do I either delete or edit the two lines from the list because I tried to do it through the etc/apt/… but I couldn’t save the changes as it said I did not have permission AND I can’t access it through Muon/Synaptics?? AND I can’t save any new version of thee source list in that file either for the same reason?

You’ll need to elevate your permissions to administrator with sudo:
kdesudo kate /etc/apt/sources.list

Thanks AJ.
A new trick! After much messing about I am nearly back in play, but now after doing the update, I think I am pointing to the wrong mirror as I get this error message:

W: Failed to fetch http://packages.netrunner-os.com/dists/frontier-14/InRelease Unable to find expected entry ‘main /binary-amd64/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/frontier-14/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/frontier-14/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/frontier-14/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Do I need to change it to:
deb http://packages.netrunner-os.com frontier-14 main #id:netrunner_main ??
If so where do I need to copy this to?

In the same file. on those lines you need to change frontier-14 to read trusty like this:

http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/trusty/main/source/Sources
http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/trusty/main/binary-amd64/Packages
http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/trusty/main/binary-i386/Packages

I think this would be right:
http://packages.netrunner-os.com/dists/frontier-14/Release
if not then you may be correct.

Did you mean for me to put these 3 lines in the source.list? That’s what I did and now it doesn’t like line 4:
http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/trusty/main/binary-i386/Packages

Here this issue was solved in this thread:
http://forums.netrunner-os.com/showthread.php?tid=16067

Okay AJ, I tried to follow what you said to Oculto in:
http://forums.netrunner-os.com/showthread.php?tid=16091 but I will try this other one tomorrow. I am beat now. Thanks for your help so far. As this issue keeps cropping up, is it something that can be fixed/ updated by the dev team?
I really appreciate what you guys do. Just may be this ‘Windows convert’ can make Netrunner feel like home…

Well, I have followed this as best I can but I am now getting the error message:

E: Malformed line 5 in source list /etc/apt/sources.list.d/official-package-repositories.list (dist)
E: The list of sources could not be read.

and the official-package-list looks like this:
deb http://packages.netrunner-os.com frontier-14 main #id:netrunner_main
deb http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu trusty main
deb http://ppa.launchpad.net/netrunner-os/frontier-14-packages/ubuntu/dists/trusty/main/binary-amd64/Packages
deb http://ppa.launchpad.net/netrunner-os/frontier-14-updates/ubuntu trusty main

deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

What else should I do? Thanks

line 5 and 6 need to be pointed here: http://archive.ubuntu.com/ubuntu/dists/trusty/

Cheers, but this doesn’t make any difference, I still get the same error. Anything else?