Samba server and client actually work?

I’ve tried open share guest folder from KDE and found out that actually impossible get access to it by a network from win7. It still ask user and password and vise versa. Is this brocken by default? Latest Frontier. Even if I provide a password system can get access anyway. :-/ .

Tested it here and can not reproduce the problem.
I right clicked the folder I want to share with samba and clicked on sharing. Enabled guest access and exited dialog.
Used IP address on a another linux box to access to the samba share.
I don’t have windows here anywhere running to test that. But it should work fine there too.

Standard Windows file sharing (workgroup or domain) requires you to log in to an active account to access shares by default, there is also the homegroup option as well:

This may be helpful:

Just checked.
Not customized Kubuntu 14.04 - samba works (Virtualbox)
Not customized Netrunner 14 - samba can’t see any shares. (Virtualbox)
My Netrunner 14 - as previous… even more… right now I can run samba server at all. (Real hardware)

[code]:~$ sudo service samba status

  • nmbd is running
  • smbd is not running

Any thoughts? firewall disabled.

Please take a look in the logs in /var/log to see if there is an error why samba isn’t running for you.

[code]:~$ tail /var/log/samba/log.%m
INTERNAL ERROR: Signal 11 in pid 1227 (4.1.6-Ubuntu)
Please read the Trouble-Shooting section of the Samba HOWTO
[2014/11/21 08:53:17.839004, 0] …/lib/util/fault.c:75(fault_report)

[2014/11/21 08:53:17.839241, 0] …/lib/util/fault.c:133(smb_panic_default)
smb_panic(): calling panic action [/usr/share/samba/panic-action 1227]
[2014/11/21 08:53:17.848619, 0] …/lib/util/fault.c:141(smb_panic_default)
smb_panic(): action returned status 0
[2014/11/21 08:53:17.848680, 0] …/lib/util/fault.c:144(smb_panic_default)

What is in the log file prior to this:

INTERNAL ERROR: Signal 11 in pid 1227 (4.1.6-Ubuntu) Please read the Trouble-Shooting section of the Samba HOWTO
It will give more insight into what is causing the crashes.

Seems like this bug appears in samba for related for FreeBSD and ubuntu relatives distros.
But error log little bit different for test system in virtual box

[2014/11/23 18:34:23.446164, 0] ../source4/smbd/server.c:370(binary_smbd_main) samba version 4.1.6-Ubuntu started. Copyright Andrew Tridgell and the Samba Team 1992-2013 [2014/11/23 18:34:23.899559, 0] ../source4/smbd/server.c:478(binary_smbd_main) At this time the 'samba' binary should only be used for either: 'server role = active directory domain controller' or to access the ntvfs file server with 'server services = +smb' or the rpc proxy with 'dcerpc endpoint servers = remote' You should start smbd/nmbd/winbindd instead for domain member and standalone file server tasks
But still smbd still dead in the both cases. I think that issue exactly with the packages. Because I have nothing like this with plain kubuntu. And here I have two distros one without any customization. Probably issue appear then I make distro up from 13 to 14. Do you have a fresh installed distro?

ii samba 2:4.1.6+dfsg-1ubun amd64 SMB/CIFS file, print, and login server for Unix
I’ve tried apt-get purge and install again without any success.

Do you have the virtualbox guest modules and the virtualbox guest utilities installed in both distributions?
Maybe if you were to copy your /etc/samba/smb.conf file from the working distrobution install to the other one and edit it for user name, etc. might work, just a thought.

Curious thing is that dpkg says that on working kubuntu no samba-server and client at all :huh:. Probably it uses something else. Of course I have guest utilites. But this is not the point for samba.

That is strange, I wonder if Kubuntu could be using NFS, or maybe it is somehow using the host OS’s network discovery instead of it’s own. I think for you, some investigating is in order here.

samba-common and samba-common-bin are installed by default. Not sure if they are enough to share files though. Normally they should only provide stuff used by samba3 or 4 server and clients and should not be able to allow creating shares.
It needs the samba package itself for this.

I don’t think Slimy is trying to create a share but to access the windows shares, or am I wrong?

He tries to create a share on netrunner which he can access from windows 7.
So he needs a samba server for this.

I not sure if it’s just bad wording or not, but I’m getting the exact opposite from that sentence.

Then slimy please clarify what you mean.