Screen Bright-Dim Not Functioning- Dell Inspiion 3521

I just installed Netrunner 14 Frontier on my Dell Inspiron 3521. Everything works well, except the screen brightness. It does not respond at all. It stays very bright. I tried both through power management settings, and holding the function key, and pressing the bright-dim key, and still no response at all. Is there anything I can do to fix this?

Thank you,

Hopefully, this will help you out:

Edit “/etc/default/grub” as root.

kdesu kate /etc/default/grub

Look for this line:


Edit that line so that it now looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"

Save and exit, then run the following command:

sudo update-grub

You’ll need to reboot when it’s done.

The back-light (brightness controls) should now be working correctly.

Hi AJ,

When I typed “/etc/default/grub”.
I got:
bash: /etc/default/grub: Permission denied
I simply opened up the terminal, and typed the line, and got denied.
I don’t know how do I get into the terminal as root. Could you tell me how to login as root to complete the task.

Thanks for your quick respnse.

Try the command

kdesudo kate /etc/default/grub

The kdesudo should ask for your user password wich grants you root rights when entered correctly.

Yes sorry, on Netrunner Standard (Ubuntu/Debian) it’s kdesudo not kdesu, I’m keep forgetting that since I’m on Netrunner Rolling (Manjaro/Arch) things are slightly different.

Hi Leszek, Aj,

Thanks a million, that did the job.

Netrunner, the best Linux operating system!