Screen line, VLC scramble, keyboard lag

I suspect that the first two of these issues are related to video drivers.

Occasionally I get a single thin horizontal line that goes completely across the screen. It disappears after a short time and doesn’t seem to affect anything in any significant way other than that it looks like the screen has a failed line of pixels while it’s there.

The VLC issue is far more serious, so much so that I avoid using VLC. It will play a video fine and then just randomly corrupt the entire display so that it’s completely unusable. This usually happens within a couple of minutes or sometimes even a few seconds after starting playback. At that point I can just barely see a large square that is the cursor move around but it’s just a slightly different colored mesh of blocks than the rest of the screen. I’ve tried to ctl-alt-bkspc to restart the video server but that does nothing. I guess it was an old X trick so maybe it’s not valid anymore. I started out with Linux on Walnut Creek Slackware CD’s so a lot of my habits are a bit on the older side. Eventually I have to just kill the power and reboot, that seems to be the only way to restore things. I could try to ssh into the box and I’m pretty sure that would let me reboot as I don’t think the system is hung up, it’s just that the display is totally corrupt and I can’t navigate. Using SM Player doesn’t seem to cause this problem but sometimes I use VLC to edit video metadata for the miniDLNA server on my NAS.

The keyboard lag issue is definitely the most severe problem of the three. There is an enormous amount of lag, maybe 5 seconds or more at times but at other times none, or just a half second, or anything in-between. The problem doesn’t seem to be a buffering issue because usually when the text finally appears on screen it’s either missing characters or has repeated characters where there should only be one, so the buffer isn’t even receiving keystroke on-off events properly. This wasn’t a problem until recently so it must have been an update of something. When this is happening the machine is basically unusable for any keyboard entry, but the mouse still works fine.

I should also mention an incident that I had today while trying to copy files to my NAS, because it might be related to the lag issue. I was copying a group of files that were about 400 MB each and after it completed the fifth file (out of about 20) the copying just stalled, but there was no indication that it had. The progress meter on the task bar continued to circle but it hadn’t filled enough to match the progress that was already completed. I eventually stopped the process and started it over in smaller groups of files and it worked fine after that, and the progress circle filled to match the file copy progress as things went through. This has never happened before either so perhaps it’s related to the keyboard lag delay and the system was stuck waiting between file copy events.

Other than these things the distro is working nicely. There are some personal preferences I’d like to change about it, like having borders around the windows, but that’s not a technical issue. I did have background and font colors set for Kate and they disappeared during an update I guess, but while that’s annoying it’s only cosmetic and doesn’t prevent things from working.

Nice article, however you mentioned nothing about your system, just gave a string of issues.
What CPU and/or GPU/s you have?
How much memory do you have?
What display drivers are you using?
What kind of hard drive/s do you have?
What network adaptor/s do you have?
Are you using Samba or NFS?
Is your keyboard and/or mouse usb or wireless?
Is this a store bought system or a custom build?
If the former what is the make and model of the system, if the later what is the mainboard’s make and model?
etc., etc., etc.

Without knowing any of this information, it’s impossible to diagnose your issues.
Please, at the very least post the output of inxi -F.

On a side note: I remember the Walnut Creek Slackware cd-roms quite well. I played with those, and many other distributions including Debian, Caldera, and even Corel linux, basically anything that came in the back of books from Barns and Noble, or that I could get in a boxed set. However, my first real install was Yggdrasil plug-and-play Linux, after all, it came as a live CD. Now for my business system, I did eventually settled on Redhat 5 Manhattan that I had bought as a boxed set from best buy. I ran that as my main OS for quite some time before switching to another box set from Best Buy of SUSE enterprise Linux. I was also quite fond of Mandrake back in the day as well.

Here’s the output. It’s somewhat difficult to work with this as the keyboard problem appears to be getting worse so even logging into my email is problematic as I can’t always get the password correct.

System: Host: HPPC-L Kernel: 4.14.47-1-MANJARO x86_64 bits: 64
Desktop: KDE Plasma 5.12.5 Distro: Netrunner 2018.01 Rolling
Machine: Type: Desktop System: HP-Pavilion product: NY549AAR-ABA p6230y v: N/A
Mobo: FOXCONN model: ALOE v: 1.01 serial:
BIOS: American Megatrends v: 5.05 date: 10/26/2009
CPU: Topology: Quad Core model: AMD Phenom II X4 810 bits: 64 type: MCP
L2 cache: 2048 KiB
Speed: 800 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800
Graphics: Card-1: AMD Barts PRO [Radeon HD 6850] driver: radeon v: kernel
Display: x11 server: X.Org 1.19.6 driver: ati,radeon
unloaded: fbdev,modesetting,vesa tty: N/A
OpenGL: renderer: AMD BARTS (DRM 2.50.0 / 4.14.47-1-MANJARO LLVM 6.0.0)
v: 3.3 Mesa 18.0.4
Audio: Card-1: AMD SBx00 Azalia driver: snd_hda_intel
Card-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]
driver: snd_hda_intel
Sound Server: ALSA v: k4.14.47-1-MANJARO
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 00:26:55:44:0d:18
Drives: HDD Total Size: 931.51 GiB used: 59.11 GiB (6.3%)
ID-1: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
Partition: ID-1: / size: 19.56 GiB used: 13.76 GiB (70.3%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 83.55 GiB used: 45.35 GiB (54.3%) fs: ext4 dev: /dev/sda7
ID-3: swap-1 size: 2.01 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 30.0 C mobo: N/A gpu: radeon temp: 37 C
Fan Speeds (RPM): N/A
Info: Processes: 196 Uptime: 6h 16m Memory: 7.79 GiB used: 3.06 GiB (39.2%)
Shell: bash inxi: 3.0.10

When did your issues start, and do they only exist in Netrunner Rolling?
Have you ran memtest on this system yet?

By default all of the opensource drivers use glamor now, your older chip may be having issues with this.
Try the following, it may help:

Well, try the EXA and other changes I linked to in my last post. The Radeon HD 6850 might just be having issues with the Glamor driver, Plasma is after all, a bit heavy on the opengl side.

Thanks for the suggestions. Your advice seems to be right on target again, just like last time! This is great!
I implemented the EXA change and it seems to have worked so far, so I haven’t tried anything else. It seemed to me after I rebooted that the browser was scrolling much more smoothly; I guess I hadn’t really noticed it dragging or just attributed it to old hardware. I even ran VLC for a few minutes on a couple of different files without problems after making the following changes.

Not working configuration.
VLC – Output: Automatic
After the EXA change gives what appears to be unaccellerated output. Slide show appearance but audio is fine. Prior to EXA change total screen corruption was inevitable after a very short time.

Working configuration with smooth output and no screen corruption.
VLC – Output: Xvideo output (XCB)
SMPlayer - Output Driver: Default

I don’t know how ‘Automatic’ and ‘Default’ are handled by the system, but I do realize that SMPlayer seems to be the default and as such it has always worked, while VLC is a package I installed afterwards so I’m not surprised if the configuration needed to be adjusted.

I used to be quite up to date with the subsytems in Linux, but that was years ago now. These days I like to use it for everything that I can without getting under the hood too much. Back around the turn of the century I had immersed myself in Linux and related systems as a job but life took a different turn and these days I don’t have nearly as much time to spend on it just as a hobby. That’s why I now look for distros like Netrunner, which have done all of the heavy lifting for me and I can just tweak for personal preferences and be on my way. Back then I worked with Open, Free, & Net BSD, Solaris, Red Hat, Mandrake, and I can’t remember what else. I had a 486 (14" monitor!) on OpenBSD running a firewall and NFS server with Debian and Mandrake machines tied into it. At one point I even stopped in at the Mandrake offices in Paris and went for lunch with the developers while I was there on a trip. If I recall correctly the 2 series kernel was newish and OpenBSD was only a few years old (4.2 maybe?) and didn’t even have a package manager with dependency management (which eventually led me to leave it). I even managed to shoehorn OpenBSD onto a 386 with 4 MB of RAM, just to see if I could get it to work. I also played around with a DECstation, trying to get it to boot without the network; I figured out how but didn’t have the hardware to do it. For the last number of years I’ve mostly run openSUSE, but messed around with Ubuntu variants and some others too. I got frustrated with openSUSE a few years ago when they moved to their Leap format but went back about a year ago and things seemed to have settled down there somewhat. I ended up on their Tumbleweed distro but after several things broke I started looking for something else and eventually found Netrunner. I like the operability and layout quite a bit but must confess that I’ve never been a fan of the flat and minimalist themes; my favorite was probably KDE 4.4ish Oxygen. Having started out coding on a Multics mainframe with a green screen Honeywell VT100 terminal I really appreciate the color, texture, and depth of a nice desktop. After all, why have 16 million colors and a GPU available if everything is flat and monochrome? Just my preference, that’s all. Obviously there are a lot of people that think differently.

Thanks again for the expert advice. I haven’t had any keyboard lag the entire time since making your suggested changes so I think it’s fixed. I’ll follow up if that changes.


Well after getting things working nicely even through several reboots, this morning I’ve sub-obtimal results.
The machine boots fine and gives me a working login window complete with cursor. When I enter my password and hit enter the screen goes black and stays that way. I can’t ssh into the box to determine what’s going on; I thought I had enabled ssh during the install as that’s my normal practice but maybe that was on previous installations of openSUSE. Does the Netrunner install have a place for setting up ssh?

The video server seems to be working as it gives me the login screen and mouse, so I don’t think it’s the EXA modification that I applied. I think there was a substatial update in the last day or so but maybe I’ve got that mixed up with the machine I’m currently typing on. I have two machines running Netrunner, both of the same vintage. This one is connected to my TV ands sees little use these days but I update it when I do use it. If I’ve typos in this message it’s because the screen is ten feet away.

I’m out of ideas for this problem. I can login but it just gives me a black screen so it’s functionally equivalent to not logging in. I can’t ssh into the box, I’ll have to change that when I can get in. The only angle I can think of is modifying boot parameters for a safe mode or something. I assume they still use runlevels? Once I get in though what do I change? Probably set up ssh and then at least I can pull logs when it reboots normally.

What do you think?
Thanks and sorry to be such a bother.


Of course a minute after my last post I remembered that I could switch virtual terminals. So a simple Ctl-Alt-F2 and I had a login prompt that worked. So now I could use a suggestion as to what logs to look at and how to enable ssh.

Okay, so another realization. When I switched back to virtual terminal 1 the GUI was there and working normally. So I’m writing this from my usual Netrunner desktop. I’ll try to reboot and see what happens and if the problem and workaround are the same.

So the problem remains, as does the workaround. Hitting enter at login gives me a black screen and the HDMI indicator appears on my screen, which I suspect means that it has lost connection or is changing connection state in some manner. When I switch the VT2 then switch back to VT1 things proceed normally. So perhaps it’s something in the X server where it’s losing the terminal focus.

I just noticed your said HDMI.
I’ve had the same issue before with HDMI output on startup, however that was with an Intel chip and the 4.14.x kernel.

You could try specifying the primary output in your X11 startup config files:

For finding the logs, systemd log parsing, etc.: