back to Netrunner | back to Blue Systems

Screenshot feature *broken*


#1

Hi there

Looks like something is broken, pressing the PrintScreen
key displays the screenshot dialog but clicking on “save on clipboard” is NOT working.

I also run the “spectacle” on a terminal , same behaviour and
there is no error message…

BUT if I run that program with sudo and click on the copy to clipboard then the screenshot app says “The screenshot has been copied to clipboard” , any idea what’s going on? KDE bug or installation went titsup ?

thanks !


#2

Thats weird. I cannot reproduce this issue.
Make sure to have the clipboard widget in the system tray.

Just to make sure if you hit the put in clipboard button no message appears for you in the app window that the image is now in the clipboard?


#3

Hi,

yes…no message (as user) ,maybe my user profile is screwed…
I will test with another user and let you know thanks!


#4

nope… second user same thing, can’t copy to clipboard.
seems apparmor permission or something? sudo a paint app (krita) and spectacle copies the screen on clipboard like a charm, not when plain user.


#5

Very weird.
Why do you think it is an apparmor issue? Do you have any debug log output of this (journalctl usually shows apparmor blocking certain actions)


#6

bit bs app, there is no debug output.

never-mind I figure it out, I use the xclip plus a custom
shortcut to copy to the clipboard, so screw spectacle
-and xclip works friggin faster than spectacle


#7

I see. I am happy that you found a workaround.
Though I would really like to know what is wrong with spectacle on your machine.


#8

no idea… mind that was fresh install on a HDD that I just got as
I have already data on the original HDD


#9

So you installed on a clean HDD or reused an existing /home ?

edit: After analyzing the issue I think I found a way to reproduce the issue you describe. The issue comes from the Quit after Save or Copy function. If you turn this off it will not close the window and copy the contents correctly to the clipboard so you are able to e.g. paste it into gimp.
This issue happens because of the slightly older version Debian ships and the default setting spectacle is using apparently.
Thanks for reporting again. And it would be great if you could confirm my finding.


#10

lovely!! yes it is working in that way! nasty bug indeed - MANY THANKS!
btw was fresh install, brand new HDD and formated