SD card reader not recognized; mtp protocol Androd works

The OS readily reads the card in an Android phone.

It finds the Android OS on the “first plug”.

A “replug” finds the Android OS and then about a half minute later the “file system” is found.

Files are readily moved from both the phone’s file system and the sd card file system to the computer by selection in the file menu and then drag and drop to the split window, using either paste or move function.

In other words “mtp file protocol” was “solved” a few years ago but it could be “laggy” or multiple plugs and replugs were needed but for this particular OS it seems to be completely functional.


When one tries to read the same sd card from the Android phone in a “card reader”, of a variety of types, the “connected” light does indeed light up, either the older green single light or the newer “two light” type the first light shows that it is connected to a computer and then the red light is supposed to change to blue when the card is “read”. But, neither type works.

Since the mtp protocol is now fully operational there is no need to open the phone and remove the sd card and use a reader, but I thought that I would report the situation.

Kudos to the develolpers. :smiley:


For the sd card reader. Is a normal sd card (so one that you didn’t use as android sd card) working ?
If not it might be that this specific reader is not recognized.
Maybe also dmesg shows something regarding the card after inserting. Just execute it in the terminal right after inserting the card and see what it prints in the last lines.

As for sharing files I usually do this over the air with sftp. I think there should be a few apps that offer ssh/sftp server for android even without rooting the phone nowadays.
It works pretty good even if the phone isn’t in the same room but on the same network.
Though I must admit I never tried copying over 12 GiB over the network yet. That can be slow depending on the Wifi network you have.

hi leszek
thanks for the reminder of dmesg
I usually install “hardinfo” and it did not show it, so I’ll try dmesg, however, I’m heading to Key Largo to dive with a disabled person, so I’ll put it off till after! :slight_smile:

thanks again