sddm goes black after any change

This is very weird. I tried to replace the default login background. However, any of the following ways I tried will black sddm:

  1. the sddm settings gui application
  2. try to replace login.png in /usr/share/images/netrunner/ to be another png picture
  3. change the picture path in /usr/share/sddm/themes/breeze/theme.conf.user

And it seems that there is no way back. Once I black sddm, I have to reinstall the system to bring it back, even if, for example, I change the path (method 3) back to the login.png.

Is it OK to replace sddm with lightdm?

Yes you can replace sddm with lightdm if you like.
More interesting would be why it is failing. Sddm should write a log file in /var/log. Can you please attach that so we can take a look what might went wrong there.

Yea, I actually checked that, but nothing noticeable. I’ll post it next time it fails … (I am experimenting with other dms)

It seems to be a problem with nvidia. It’s a new laptop with only the nvidia card. I google a bit and find several people face the same problem (go black). I tried lxdm and it goes black after 3 seconds…

How is lock-screen handled? It seems that the lock is provided by sddm (also for suspend). Any way to completely avoid sddm?

lightdm seems have the best compatibility (and I really like the lightdm-kde-greeter, so kde-feel). So far so good. I’ll run it for some days and see.

Lightdm seems to work for session start. But “sleep” now has issue. It can go to sleep, but after recover the screen is black with only a freezed cursor. How do I configure “sleep”?

The lock screen is not sddm though it uses the same look.
When it comes to sleep it is basically not configurable. It either works or not.

You are right. I cannot get “sleep” to work properly. I believe it is a nvidia issue. So unfortunately, I’ve been using netrunner since the end of crunchbang, and I really like plasma 5.

Right now I have to use xubuntu instead. Wait for my laptop to become “old” enough to be compatible.

What about trying a different driver ? Do you have the nvidia proprietary driver installed or do you use the free nouveau drivers?

The proprietary. I tried both 352 (latest in the ubuntu repository) and 358 (latest on Nvidia website). I also tried installing kernel 4.3.3.

Nouveau cannot even make it to livecd (have to add nouveau.modeset=0).

The hardware is pretty new. Wireless card isn’t supported by the version of kernel on Debian stable yet. Opensuse and manjaro cannot boot to installation no matter what boot parameters I set … Fedora has problem with UEFI. It seems fine on legacy BIOS, but is not detected when I install it on UEFI. Weird. The other distros have no problem with EFI.

Ubuntu seems to have to best compatibility but unity is a deal breaker. Kubuntu has the same problem as Netrunner. Xubuntu is right now the best “workaround”.