sharing folders over LAN

I am new to Arch, but on netrunner since day1,
having been acustomed to right click>Properties>Enable sharing,
I noticed that a folder is not shared like that in Rolling, although samba is installed.
Do I have to do something extra?
thank you all!

You were actually almost there, all you need to do is right click>Properties>Share>then enable “Share with Samba (Microsoft Windows)”. You should be fine with the rest of the options there, the new dialog is more windows like IMO.

Nope, that’s what I was doing. It is not working :frowning:

KDE, has the ability to browse Samba shares built in. Therefore do not need any additional packages. However, for a GUI in the KDE System Settings, install the kdenetwork-filesharing package from the official repositories.
If when navigating with Dolphin you get a “Time Out” Error, you should uncomment and edit this line in smb.conf:
name resolve order = lmhosts bcast host wins

I have not been using windows for over a decade, so it is not the lack of resemblance that troubles me.
Up till now, I used more user friendly distros, with samba preconfigured.
And I had to do nothing more than that. And as far as I remember I never had to do nothing more than what you describe.

This time though, it is not “just working”. I have kdenetwork-filesaring installed.
And it is not that I get a T/O error. I can’t share a local folder with my network.

After I enable samba there is nothing happening (like a pop up for enambling/ configuring samba shares),
and after that, if I reopen dolphin the icon indicating a folder as shared is missing, allong with the enabled option in the sharing tab.

I’m not to sure as I don’t use Samba normally, but I did this in a terminal:

cp /etc/samba/smb.conf.default /etc/samba/smb.conf
systemctl start smbd
systemctl start nmbd
systemctl enable smbd
systemctl enable nmbd

to enabled the samba server, then I logged out and back in and can access my sons netbook shares now, I haven’t tried to set up sharing the other direction yet. hopefully this link help you out:

PS. If you get this working maybe you could let us know what you did so the NR/Manjaro developers can fix this in the next ISO/update scripts.

I am afraid what you proposed did not work.
I have checked the wiki, but is far more complicated than I can understand.
Are you experiencing the same problem, or is it just me?
I am in love with this OS (rolling), and that could break the deal, dammit!
Anyway thnx for the help.

If anyone has a clue, plz let me know!

Thank you!

I think I’ve got a clue. (and hopefully we will be able to ship a fix with the next snapshot aswell)

The usershares folder defined by default in smb.conf is not existing which causes this problem.
To fix it you need to do the following steps:

1. Open up a terminal and type in the following to create the directory

sudo mkdir -p /var/lib/samba/usershares

2. We need to create a group for the usershares folder. Execute in terminal:

sudo groupadd sambashare

3. Usershares folder should have group owner set to this newly group. So execute:

sudo chown root:sambashare /var/lib/samba/usershares

4. Correct the permission of the usershares folder for all users to be able to create shares from GUI (which are magically linked in this folder basically). Execute:

chmod 1770 /var/lib/samba/usershares

5. Add your current user to the sambashare group. Execute:

usermod -a -G sambashare YOUR_USERNAME_HERE

6. Restart smbd and nmbd with the following command

sudo systemctl restart smbd nmbd

7. Relogin. (Logout and Login again) and configure your share again. It should now appear when accessing your computer via smb.

If it asks for your user password on access and it does not login you need to set a smb password for your current user on the server by executing

sudo pdbedit -a -u YOUR_USERNAME_HERE

and entering the password.

I hope that works for you.

I haven’t time to test this right now, but I will later today. I also hope this works,

dolphin(2976) KSambaSharePrivate::add: We got some ehile running ‘net usershare add’ (“usershare”, “add"loads”, “/media/DATA/Downloads”, “”, “Everyone:r”, “k=y”)
dolphin(2976) KSambaSharePrivate::add: "net usersharshares are currently disabled

So it does not work ?

The error message looks a little bit weird as it states


Is it a typo or did you copy the error from konsole ?

It does not work,
I copied from console!

This may or may not be not a typo but those errors are because

1: Since smb.conf is not created on a new install this needed to be step 1:
sudo cp /etc/samba/smb.conf.default /etc/samba/smb.conf

2: need to change these lines in smb.conf
workgroup=MYGROUP > workgroup=WORKGROUP
; name resolve order = wins lmhosts bcast > name resolve order = lmhosts bcast host wins
3. these commands that we’re given needed modification:

  1. Correct the permission of the usershares folder for all users to be able to create shares from GUI (which are magically linked in this folder basically). Execute:
    sudo chmod 1770 /var/lib/samba/usershares
  2. Add your current user to the sambashare group. Execute:
    sudo usermod -a -G sambashare YOUR_USERNAME_HERE

I tested this and the commands that were given now take without issue, and I can see and access folders on other machines, however I still can not share folders from this machine.

Still not sure what the problem is, but under properties>share you can select share with samba and the drop downs in the window works, however all the users are grayed out, and if you close and reopen dolphin the folder no longer has the shared icon. AKA still not working…

PSS. I also noticed that samba seems to be working correctly on the live image, just not on a installed system, kind of like Plymouth.

my question still remains, am I doing sth wrong or not?

No, it’s not you, the installed system just isn’t set up like the live CD was, this will need to be ironed out by the development team and then all we will need is a script added to a future update. You just need to understand that most arch packages are designed for a DIY system, Manjaro tries to take that and make it more user friendly through their manjaro-system scripting package, a few other custom utilities, and sometimes custom patches applied to select packages for their repositories, but unlike Ubuntu these changes are not proprietary to them, and don’t break compatibility to upstream, etc.

oh ofc I understand. That’s why I am trying to learn and understand linux.

Yeah I discovered that the smb.conf from live media isn’t there on the installed system.
kab00 could you try copying the /etc/samba/smb.conf from live media to your installed system and see if this then works for you ?

Yes, the installer doesn’t copy the live session, it uses a compressed file on the media to install from and then runs some scripts to set the system up. If these changes are not part of the installers scripts then this is the reason for this and some other minor issues like Plymouth not being setup after install. I will let The Manjaro developers know about these issues with the installer.

to do this, should I run live again?
or just browse the DVD and c/p ?

I would recommend live system.