Skype no sound

I have just upgraded (32 bit) via the script, and almost everything works or has been easily fixable. Except Skype sound. There is something basically wrong about sound, as on startup a message comes up telling me so and that therefore I am using “default”. For everything else this is OK, but not for Skype. I have searched extensively for solutions, most of which are about adding 32 bit Pulse to a 64 bit install. I have a 32 bit install and all the suggested items are present.
At I find what ought to be a solution but when I open the PulseAudio Volume Control I get:

"Connection to PulseAudio failed. Automatic retry in 5s

In this case this is likely because PULSE_SERVER in the Environment /X11 Root Window Properties or default-server in client.conf is misconfigured.
This situtation can also arrise when PulseAudio crashed and left stale details in the X11 Root Window .
If this is the case, then PulseAudio should autospawn again, or if this is not configured you should run start-pulseaudio-X11 manually."

I have found a client.conf but have no idea how to configure it.

How should I proceed?

First take a look in the systemmonitor if pulseaudio is running. My guess is it isn’t as ‘default’ is usually a alsa soundcard device.
You can also try to reinstall pulseaudio via the packagamanager.

Pulseaudio is not visible in the System Monitor. I have tried reinstalling it, Phonon -System Settings is now showing pulse (and oss) as well as alsa, and the HDA Intel PCH (ALC892 Analog) which previously failed testing, now tests OK. As do most of the HDA Intel PCH (ALC892 * entries. But pulse does nothing when tested.
I tried pulseaudio --start but it came back with:
E: [pulseaudio] main.c: Daemon startup failed.

So something is odd there. It just does not want to start up. Can you try removing all configuration files in /etc/pulse and try again. You need root rights for this

rm’d both .conf files from/etc/pulse and tried again:

$ pulseaudio --start
E: [autospawn] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Permission denied
W: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
E: [pulseaudio] main.c: Failed to acquire autospawn lock

So I changed owner and user group of /run/user/1000/pulse to andy and tried again, but:

$ pulseaudio --start -v
E: [pulseaudio] main.c: Daemon startup failed.

Change the permissions back and then run:

sudo pulseaudio --start -v

OK, put permissions back to root and ran:

W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
E: [autospawn] core-util.c: Home directory not accessible: Permission denied
W: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
E: [pulseaudio] main.c: Failed to acquire autospawn lock

I have now installed Netrunner 14 64 bit on another drive. Skype works there except for a lot of white noise and a muffled sound on the mic input. I have tried a variety of things, setting the latency up and down, trying appending “tsched=0” to load-module module-udev-detect and load-module module-detect in /etc/pulse/, turning various things on and off, to no effect.
As my use of Skype is infrequent but vital, using the other drive just for that is OK, until I can get it set up properly. So can you suggest how to get rid of the white noise?

Poor sound on the 64 bit install is now SOLVED. As well as the webcam I had a desk mic plugged in. This has never been a problem before. I unplugged it and got no voice, just white noise. I then moved the webcam to the top of the Phonon Audio Recording list and got clean sound.

That problem is solved. If the script-updated 32 bit install can’t be fixed I can move over to the 64 bit, which I had hoped to avoid as it is fiddly and time -consuming.

The home directory not accessible is bothering me. Can you try removing any hidden cache files in your home .local/share and .cache directories.
Also to make sure it is really the home directory you could create a new test user and confirm if pulseaudio is working there.

I have removed a lot of cache files to no effect. I have also created a new user and Skype has no sound there either.

The messy sound on the 64 bit clean install is fixed - see above.