Slow startup after logon

This is my first time trying this distro. I’m noticing that after I enter my password upon booting up that it takes around 30-40 seconds before I get to the desktop. Is there a way I can speed this up? What is loading between login and getting to the desktop?

Thanks!! :slight_smile:

Hi, Firefox is preloaded in the background upon login, so it does start almost immediate when the icon is pressed.
We will see if we can squeeze some more time out of the LTD (load-to-desktop) after login via the next updates.

delete all crap like ffox in


There is only one Firefox related file in that location, removing it won’t speed up the LTD (load-to-desktop).
Most of the delay with Plasma loading to the desktop is related to background services and plasma itself.

Well, that and network manager issues:

Removing the [color=#333333]virtualbox-guest-X11 virtualbox-guest-utils [/color]package (if installed & not needed) might help.
[Ref: Slow to load desktop from login screen, Posts #22-25]

Although this does work in Netrunner Debian, it may not apply here, but worth a try.

We don’t have a virtualbox-guest-x11 pakage in NRR (Arch/Manjaro).

Do you mean the guest kernel modules?
These are usually only loaded when installed in virtualbox (NRR is guest).
Now, there should be a host kernel module loaded when installed to bare metal (NRR is host).

Or do you mean the guest-utils (guest additions when NRR is guest), or guest-iso (guest addition ISO for use by other guest OS’s when NRR is host)?

Another shot in the dark. What kind of HW do you use? If it’s an older intel centrino chipset with an S-VIDEO out following Kernel/grub parameter might help. Just add to your grub config: video=SVIDEO-1:d


So your running NRR inside virtual box without the virtualbox-guest-utils?
You do know that you won’t be able to use drag or drop, graphics acceleration, or full virtualization without them?
Do you not have VT turned on in your BIOS/UEFI?

I never said nor implied, I nor the OP was running NRR in guest mode.
If anyone is using VB, then this is not an option, even if it works.

I’m running Netrunner (Debian) rolling. But noticed the OP’s similar question that was posted in Maui forum, which leszek suggested removing virtualbox-guest-X11. Since I’m not using VB, I removed the package and, no more delayed startup.

rmcellig, If [color=#333333]virtualbox-guest-utils[/color] is installed and not used, remove it. If that doesn’t work, reinstall it. And yeah, it a shot in the dark, but no harm in trying.

I just checked my test systems install and virtualbox-guest-utils and/or the guest modules are NOT installed.
What IS installed is the virtualbox-guest-iso and the host modules.
This means that the calamares mhwd module did it’s job properly during install.
If the ISO is booted under vbox, then the Calamares mhwd module will install the guest modules/guest-utils to the target system.
If the ISO is booted on bare metal, then the Calamares mhwd module will install the host modules/guest-iso to the target system.

Now that you’ve verified that virtualbox-guest-utils are not installed by default. And, provided the OP might not have installed it, then my suggestion is an invalid fix, as I noted in my 1st post “[color=#333333](if installed & not needed)”[/color].

Are you having the same issue as the OP?

Sort of, Plasma 5 is just slow to load even on Manjaro KDE edition and vanilla Arch.
Nevertheless, we are looking into this.