slow system shutdown

Hi Everyone.

Long time FreeBSD/linux user, but I haven’t had to dig deep into any system for so long, I’m out of touch with the details and changes that have been happening recently.

Anyway, my issue:

I recently installed netrunner rollong, at first startup and shutdown was pretty snappy (KDE startup was a little slow, but that’s another issue). Startup took around 30 seconds or so and shutdown around 15 seconds or so.

A few weeks ago shutdown started taking longer around 90-120 seconds or more, which is a bit annoying.

As far as I can tell nothing had changed before this change in behaviour. I’ve made sure the system is up to date and the issue still occurs.

Some investigating suggested that it might be systemd making the shutdown slow. I tried to poke around some of the systemd logs, but frankly I wasn’t convinced I was looking in the correct place.

Does anyone have any pointers for locating what’s holding up the shutdown process?


This is caused by a bug in systemd:
This should be fixed in systemd 230.

For now to speed up the startup and shutdown, navigate to system settings > other > systemd > conf and change the following settings from 90 to something your comfortable with:


Yep that thread seems to match what I’m seeing - occasionally shutdown time is normal occasionally long.

Thanks for the help.

Maybe it helps to set KillUserProcesses to yes in /etc/systemd/logind.conf.

That option isn’t available in the current systemd 229.
Once systemd 230 hit’s the repository that setting will also be included with the update.

Oh, so they removed it in 229? It was there in former versions and “no” was the default…

No, your right, I read it wrong.
They just changed the default setting for KillUserProcesses from false to true in 230.
Unfortunately, 230 is still in arch testing so it will be some time before it hit’s Manjaro stable.
For now use systemd-kcm to change this setting to either true is recomended.