[Solved]14 Frontier LTS Update Messup

I updated on 1-23-2015 and saw Muon as one of the updates.
All of Muon are gone
Internet connections went wacky, had to redo.
Password problems.
A new unknown Red X Task Manager or whatever has appeared in the task bar.
Firefox has a new and can’t get rid of larger icon also in task bar to the right.
Screen flashes on start up.
If anything is opened, I have two of them.
Started seeing bug report screens pop up. Did not send because of time.
System Settings has no view to display and closes

On that day ( 1-23-2015 ) in the log:
Shows a lot of things repeatedly half installed and finally not installed. Muon items are some of those, as well as mentioned by AJSlye: the issue is in the netrunner-apt-config package

I did a sudo apt-get update and upgrade. Only a few things were done. One in particular was the file mentioned in the forums: bgloo or something like that.

After that I reinstalled all that was missing with Synaptic Package Manager, after a reload and they are working. But still have quirks that I am very uneasy about.

I got the Red X off the task bar but believe it is still around.

Can not get rid of second Firefox icon in the right task bar:
Well, this is embarrassing.

Firefox is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page.

You can try:

Removing one or more tabs that you think may be causing the problem
Starting an entirely new browsing session

Copy and paste sometimes disappears from this hard drive. Not if I paste to Dozz drive.

With all this I can not post to the forums on that day and the 24 day: Password problems.
I will wait for the 15 version because of all this and remove this from the hard drive until then because I really believe this is all related to things beyond Netrunners control. Whatever that would be.

I will try to post this today using Netrunner or Dozz or Fedora.
I will be back with Netrunner 15. I may install 14.1 LTS.
The last time I had major trouble it was when I used Muon Update. Old man and Old school here-I just reinstall, to be sure, besides, I like to play.

Update: I could not wait. I am now using 14.1 complete reinstall. Sure do look good. Thanks

I think we could have fixed it, but glad you enjoy 14.1!

Yeah we are sorry for this. For a couple of hours the update was broken or at least it had the potential to break the systems systemsettings and some plasmoids. Sorry for the inconvenience.

I do not mind the reinstall and will do another with the Netrunner 15 as soon as it is here. I appreciate the help you guys offer and give. No more time than it takes me to download a new upgrade and install it or reinstall the same version fresh is ok with me, I learn something each time to so to speak-pass it on to others here, at home and to friends when needed. I have learned many ways to install all brands of Linux next to win XP - Win 10 and they work. I don’t mine breaking things, fix a little if not all - reinstall if I have to.

You folks are great,