[SOLVED] About Software Properties

Two different softwares if installed from 14.1 frontier or updated from 14.06.
SWP_1 from 14.1
SWP_2 from updated installation.

How to install the first one in 14.06 ?

Thanks for your suggestions

The package should be called software-properties-kde

Yes, in both case the name is the same but lead to different python scripts !


The package name for the second is mint-sources and not software-properties-kde.
They might use the same name though for executing.

We recommend removing mint-sources as it lead to problems in the past.

OK I just tried, in that case software-properties-kde and even software-properties-gtk dont run.

What’s the error message they show?

I tried to reinstall all software-properties files with no improvements.
Then launch in console :

File “/usr/bin/software-properties-kde”, line 136, in
app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=afile, attachWinID=attachWinID)
File “/usr/lib/python3/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py”, line 64, in init
SoftwareProperties.init(self, options=options, datadir=datadir)
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 109, in init
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 599, in reload_sourceslist
File “/usr/lib/python3/dist-packages/aptsources/distro.py”, line 89, in get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Netrunner/trusty

May be that could help :
Thanks for your interest.


Make sure to have netrunner-system=1.0.53 installed. This should fix this issue.
You can either make sure via synaptic or use the command line

sudo apt-get install netrunner-system=1.0.53

Thanks using the command line solved the issue.