back to Netrunner | back to Blue Systems

[Solved] After upgrade Testing no device in Volume widget

Hi All,

After upgrading to Debian Testing today (all packages) I get no devices found in the Volume widget. Any ideas? I’ve tried downgrading Pulse audio back to version from stable (10.0) but no luck.

Could it be the new kernel?
Can you try booting the old kernel (which should be still installed and selectable in the boot manager)

And again. We do not recommend to have Debian Testing on all the time just temporary as upgrading base for a new Plasma version in backports.

Hi leszek,

I’ll try the old kernel tomorrow and if it doesn’t work I’ll try to downgrade everything back to the 17.10 snapshot… then I’ll let you know how it went…

OK, I’ve reverted everything back to Netrunner 17.10 snapshot 20170904. All worked fine, except Pulseaudio. I’ve found out that Pulseaudio doesn’t start automatically when logging in. When I start it manually it works OK. Where is the setting to start PA automatically in Netrunner?

The pulseaudio package should provide a pulseaudio.desktop file for autostart in /etc/xdg/autostart . If it isn’t working maybe you have it turned off in systemsettings -> startup and shutdown.

OK, I’ve checked it there and it is still in /etc/xdg/autostart. I’ve tried to run the startup script and got the following error:

Connection failure: Connection refused pa_context_connect() failed: Connection refused

I have found the same error in .xsession-errors so it must be a problem with the startup script. Any idea?

OK I’ve fixed it, but no idea how. I’ve copied over all files from /etc/pulse from a default Netrunner 17.10 installation in Virtualbox to the not working installation and after that it started working. The only file that was different was /etc/pulse/default.pa, so something must have been screwed up by the upgrade to Testing in that file, but I haven’t done the diff before overwriting it. Anyway, it works now, so all is OK.

Just to confirm your point Leszek, since you test the Netrunner releases based on a certain Debian snapshot, I will continue doing the snapshot-to-snapshot upgrades, since that has proven to be the most painless and successful way (even better than using the Netrunner backports).

can you please explain the reason for this complicated procedure? The new plasma version is in the backports but I have to activate Debian testing to get the new version???

Ciao!

Dieter

Newer Plasma versions are compiled against current Debian testing. So it needs Debian testing activated to pull its dependencies.

Why don’t you rather propagate the snapshot to snapshot upgrade path instead of backports? From release to release you have the snapshot tested and upgrade from one state of Debian testing to other state of testing is always possible, since it is a rolling distribution. That way users would always have the set of packages that was intended in each of the Netrunner releases and would just hop from one Netrunner release to the next one and so on. You wouldn’t have to bother with backports…

compiled? Against ??? Why “against” What does this mean? Why aren’t you doing this sort of things in one enviroment? This stuff sounds so complicated …

Ciao!

Dieter