back to Netrunner | back to Blue Systems

(SOLVED) Blank screen after logo when running 1908 live


#1

I’ve tried adding vga=normal nomodeset, but it didn’t do anything. I can get it to boot into a terminal but can’t make it init 5. This doesn’t happen with 1901. Secure boot is disabled and other live distros are working fine.

The only thing I can think is that the new kernel doesn’t like my hardware. If anyone has any suggestions I’d be glad to hear them.


#2

Which hatdware do you have?
If it boots to the shell can youbenter startx to see what it does?


#3

It’s a lenovo ideapad 110S-11IBR. startx comes back with the message “unable to connect to xserver: connection refused”.

I’m going to try booting the live stick on my desktop to see if it works.
EDIT: Booting live on my desktop works perfectly


#4

That is a hardware specific problem. The Ideapad ships with an Intel Celeron N3060 with HD400 graphics that unfortunately does not run with the modesetting driver that all other intel graphics chips run with.
For it to go get working on the terminal after you booted live do these steps:
1. Stop SDDM Login Manager

systemctl stop sddm
2. Copy the Intel confguration file to force the intel driver instead of modesettings driver

sudo cp /usr/share/doc/xserver-xorg-video-intel/xorg.conf /usr/share/X11/xorg.conf.d/11-intel.conf

3. Start SDDM Login Manager again with the forced intel driver in place

systemctl start sddm

That should get you going. If you experience graphics glitches switch to the OpenGL 3.1 under systemsettings -> display -> compositor.


#5

Thank you for this, I thought it might be something like that.

I’ve entered the commands and none of them have complained, but nothing has happened either. What should I do to get out of the shell?


#6

The last one should’ve started the graphical user interface and show you the desktop.
Can you chack by pressing Ctrl+Alt+F7 if the desktop is running there?


#7

ctrl+alt+f7 isn’t doing anything.


#8

Can you check if .local/share/Xorg.0.log is showing anything or if startx is working now.


#9

I got it working, I changed the boot option to 3 and that made systemctl start sddm launch the desktop. Thank you; I really appreciate it.


#10

Nice. Please edit the title of your initial post and add [solved] to it