(SOLVED) Blank screen on Install

I’m having some trouble installing Netrunner on my machine and am hoping for some suggestions.

Awhile back I saw Netrunner and like the look. I downloaded 13.06, used the live CD and it would blow up everytime I tried to run Firefox. Same when I tried it in a VM, no go. At that point I gave up and just continued to use KDE on Ubuntu.

Saw the recent update to 14.1, thought I’d give that a try. Loaded it into a VM and it works very nicely. Has a lot of great features. So, I decided to actually do an install. I put in the live CD, I get a bit of the Netrunner boot image, then get a black screen with a cursor that for awhile moves with the mouse. Then after awhile it just stops responding and stays black. So, can’t get the live CD to even boot (checked on another machine to see if the CD was corrupted and had no problem booting into the main desktop).

At this point I’m suspecting that it’s my video card. It’s an onboard Nvidia card. I’m betting that it needs the proprietary drivers to render the original graphics. I would expect that I can get those once I get an install, but how to get the install? Any tricks anyone can recommend?

I should also say I’m currently running 14.04 Ubuntu and had no trouble with the install. So, not at all sure why I’m having trouble here. Maybe something unique to KDE or to Netrunner?

Try to boot into a terminal session. Does it work? Can you login? You should press Ctrl+Alt+F2 when booting. But first check what the wisdom of the Internet says about your graphics card vs Linux and KDE.

Try booting in failsafe mode.
If during boot (if you press Escape to disable splash) something like GPU Lockup appears try booting with the boot option nouveau.noaccel=1 that you can enter by pressing Tab (the key on the left from q) on the bootmenu.

Hope that helps.

Interesting thoughts. I may not have made it clear in my post, I am running 14.04 Ubuntu on the machine now. I was able to run Netrunner in a VM on the machine with no problems. I have Steam running on the current install, so the graphics card does work under Linux and KDE (at least KDE in a VM).

If I’m understanding you correctly, Ctrl-Alt-F2 during the boot phase of the live CD will get me into a terminal. I’m not clear how I would log in from there as the live CD just boots to desktop. And, I’m not clear once I log in, how I would then install Netrunner. Any suggestions there?

Thank you so much, that did it… Well, at least it got me to the desktop, I haven’t yet tried to install, will try that when I get home this evening. Looking good.

Welp, turned out to be close, but no cigar. I was able to go through the entire install. First boot, I got to the main desktop. Nice, thought it was all okay. Then hooked it up to my large screen. The boot couldn’t find the resolution. Okay, so back to a small screen. But then, problems began when I hit the desktop. I’m able to move around at first, then there is some kind of crash and nothing works anymore. And, after a bit the video is just random colors on the screen. I’m betting video drivers, but don’t have time to attempt to install before the whole thing crashes. I even did the nouveau.noaccel=1 in grub. Things loaded faster with that (or at least seemed to), but then crashed in the same way.
Any thoughts about what I might try from here?

The last option would be booting with a generic video driver by entering the following as a boot option in the boot menu

Is nomodeset a parameter for nouveau? When I added it by itself I got command not found.

Also, what appears to be the place the problem starts is when I go to the menu. I was able to bring up Dolphin with no problem from the task bar, but got freezing and the video crash each time I invoked the menu. If I’m correct about this, that would seem diagnostic, but is beyond me.

Nope its a parameter on its own.

Okay, then, not a command that is available during boot.

I burned a copy of Kubuntu just to see if that would work. The live CD booted without any intervention, but I got the same stall and crash when I went to the menu.

It appears that something happens in the video driver at the point that I bring up a menu. Is there some way to move over to the correct proprietary driver without going to settings? I’d apt-get install, but don’t actually know what driver might work.

I’d really like to get it to work. KDE is my preferred platform and Netrunner is beautiful. Very weird that I had no problems at all running it on the machine as a VM, but total crash city when I try to run it on hardware. I even had a compiz like cube running in the VM. That I can’t even get a basic desktop on the hardware is just weird.

Its a normal boot parameter. Just instead of nouveau.noaccel=1 type in nomodeset at the end of the live boot prompt. (Maybe I did not make that clear :P)
This should boot into failsafe graphics mode. So you should not get a graphical bootsplash anymore but a textsplash instead. A weird resolution maybe also but it should let you boot into the desktop and install everything without freezing.
When installed you can then run the driver manager to install the nvidia driver.

Sounds like I was not clear when I asked if nomodeset was a parameter. When I added it to the boot, just before the if statement, I got command not found. That’s why I asked if it was a parameter.

So, if I’m understanding correctly nomodeset should be a command available to the boot. Strange then that it wasn’t there when I tried it.

I’ll try again and see if it somehow shows up. Please let me know if you think of anything else as well. Thanks.

Okay, I have been able to solve the problem with some minor glitches.

side note:nomodeset totally does not work from boot. I only get command not found when putting it in the boot script.

I went back to the live CD using the nouveau.noaccel=1 parameter. Went to the settings menu, found the video driver section, opened that, and waited for it to determine my hardware. Then chose a recommended driver (304.125) in my case, applied it and checked to see that it worked under the live CD. All was good.

Went back to the boot from the hard drive. Hit ctrl-alt-F2 at the login prompt and brought up a command line. Logged in with the command line.

Note: kept getting a message like a heartbeat telling me that there was no cache space on sdb. Not sure what was happening there, or whether that heartbeat is part of the overall problem.

In any case, went to another computer and used synaptic to look up nvidia drivers found nvidia-304-updates, went back to the machine with the command line open and did an apt-get install nvidia-304-updates. Then shutdown and rebooted.

Logged in at the login screen and got a desktop. Waited for a very long time for things to load. Some things never loaded. The three icons on the desktop did not load and nothing loaded to the task bar at the bottom of the screen. However, the mouse worked and right clicking the mouse did bring up a menu. Clicking on the task bar at the bottom brought up the widget menu. I used that to install a menu button. Got a more traditional looking menu than Netrunner normally has, but it works.

Set up four desktops, changed wallpaper, did some other things. Everything works. So, problem solved, though it would be nice to have the Netrunner desktop icons and the Netrunner menu on the taskbar. They didn’t appear to be available from the widget menu, but I may have missed them. Any thoughts on that last piece?

Just wanted to say that I figured out how to get the default behavior of Netrunner. That is the default desktop and default task bar. When creating a new Activity the option of Desktop Icons will give the default Netrunner desktop with the default icons.

The task bar turned out to be a choice as well. Right clicking on the taskbar gives a menu. On that menu is an item Pannel Options. Hovering over that option gives a menu. On that menu is an option to Add Panel. Hovering over that option gives a list, one item of which is Default Panel. Choosing that option gives the default Netrunner task bar.

At this point, all my issues have been resolved. I hope that the resolutions I’ve found are clear just in case there is anyone else out there with similar issues.