[SOLVED] broadcom wifi

Hello I cant get wifi working on netrunner 2017.7 my adapter is a pci Broadcom 4360

Did wifi work for you in the live session?
Your chip should work with the broadcom-wl driver.
Please provide the output of inxi -N.

here you go and yes wifi was working on live session
esuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System: Host: ron-pc Kernel: 4.11.10-1-MANJARO x86_64 (64 bit)
Desktop: KDE Plasma 5.10.3
Distro: Netrunner Rolling
Machine: Device: desktop Mobo: ASRock model: Z97 Extreme4
UEFI: American Megatrends v: P2.50 date: 07/27/2016
CPU: Quad core Intel Core i7-4770K (-HT-MCP-) cache: 8192 KB
clock speeds: max: 3900 MHz 1: 3892 MHz
2: 3903 MHz 3: 3901 MHz 4: 3894 MHz 5: 3897 MHz
6: 3899 MHz 7: 3880 MHz 8: 3896 MHz
Graphics: Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Display Server: N/A drivers: intel (unloaded: modesetting)
tty size: 61x22
Audio: Card-1 Intel 9 Series Family HD Audio Controller
driver: snd_hda_intel
Card-2 C-Media CMI8788 [Oxygen HD Audio]
driver: snd_virtuoso
Card-3 Logitech Webcam Pro 9000
driver: USB Audio
Sound: ALSA v: k4.11.10-1-MANJARO
Network: Card-1: Intel Ethernet Connection (2) I218-V
driver: e1000e
IF: enp0s25 state: down mac: d0:50:99:71:21:bc
Card-2: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 1220.3GB (6.4% used)
ID-1: /dev/sda model: KINGSTON_SA400S3 size: 240.1GB

       ID-2: /dev/sdb model: INTEL_SSDSC2BW24 size: 240.1GB                                                           
       ID-3: /dev/sdc model: Samsung_SSD_840 size: 250.1GB
       ID-4: /dev/sde model: Samsung_SSD_850 size: 250.1GB
       ID-5: /dev/sdd model: INTEL_SSDSC2BW24 size: 240.1GB
       ID-1: / size: 186G used: 7.4G (5%) fs: ext4 dev: /dev/sdd2
       ID-2: swap-1 size: 36.77GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
       ID-3: swap-2 size: 36.77GB used: 0.00GB (0%) fs: swap dev: /dev/sdd3

Sensors: System Temperatures: cpu: 46.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 203 Uptime: 3 min Memory: 1378.6/31878.8MB
Init: systemd Client: Shell (bash) inxi: 2.3.23
[grumpy@ron-pc ~]$

grumpy@ron-pc ~]$ inxi -N
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
Network: Card-1: Intel Ethernet Connection (2) I218-V
driver: e1000e
Card-2: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter
[grumpy@ron-pc ~]$

In system settings open hardware detection.
Is broadcom-wl marked as installed?

bcm 4360 is in there

That is not what I asked.
Is the broadcom-wl driver marked as installed under system settings > hardware detection?
If the driver is not marked as installed then right click on it and install it.
Like this:

I am just reinstalling as some things dont look right I will get back to you its 1 AM here will post when I finish install

Well I reinstalled didnt get wifi working it appears to be the 4.11 kernel as I found on manjaro xfce 17 I had to revert back to kernel 4.4 so will try that later

Since I do not have that Broadcom chip, I can not reproduce the issue.
But if it works in the live session, it should also work on the installed system, both are running the same kernel.
Please, check in the live session to see if it’s using the proprietary broadcom-wl drivers, or if it’s using the opensource b43 drivers and firmware. If it’s the former, then you may just need to install the wl drivers on the installed system using the hardware detection (configuration) manager.

You said you know it works with the 4.4 LTS kernel, which since Netrunner Rolling is based on Manjaro is easy to change with the kernel manager, but have you also tried the using the 4.9 LTS kernel?

ok I downgraded kernel to 49 wifi worked right away ok thanks for your help AJ
regards ron
also I forgot to tell you calamares keeps crashing when installing netrunner from usb stick but works ok from dvd install

Did you use dd, or some other utility like ISO imagewriter, to write the image to the stick in raw mode?
These are hybrid ISO files and do not work properly if written with unetbootin or similar utilities (AKA any utility that partitions, formats, and extracts the ISO to the stick.)