[solved] Calibre broken?

I have a lot of ebooks and a separate ebook reader, therefore I’ve used Calibre a lot (on my former system). Now I wanted to install calibre on my Netrunner 17, but that seems to be impossible?

calibre : Hängt ab von: calibre-bin (>= 2.33.0+dfsg-1build1) soll aber nicht installiert werden
calibre-bin : Hängt ab von: qtbase-abi-5-4-2
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

$ apt-cache policy qtbase-abi-5-4-2
  Installiert:           (keine)
  Installationskandidat: (keine)

So how do I get Calibre and my ebooks managed?

It cannot be installed as it is compiled against the Qt 5.4.2 version and since Plasma 5.5 Update from Kubuntu Backports ships 5.5.1 the Ubuntu version is incompatible with this.

We are working on a solution.

Update: Should be fixed. We put a new version of calibre in our repository compiled against Qt 5.5.1 from Kubuntu Backports ppa.
Please update your sourceslist and try installing again.

:heart: :blush: :cool: Thanks so much :smiley:

it is better, and more up-to-date, to install calibre from the calibre website. Just copy/paste the line of code into a terminal and hit return - always installs perfectly.

Thanks for the advice but I don’t think it is better to install something that’s not compiled against my distribution’s packages. And I prefer to update through apt so that the package management knows the package and I can update it with the rest of the system.