Netrunner Home

[SOLVED] Cannot connect to Windows 10 instance over rdp protocol anymore


#1

Using krdc on a NR 2019.04 system I cannot connect over rdp to a Win10 instance in Hyper-V running on a Windows Server 2012 R2 since the last update of freerdp from 1:2.0.0_rc4-4 to 1:2.0.0-rc4-6. The rdp connection to the server itself (Win Server 2012 R2) is working.
I am using several machines with different hardware running NR rolling 2019.04 with the same issue. Only one machine where the latest system update is about two weeks ago (so on that machine freerdp 1:2.0.0_rc4-4 is installed) is connecting to the win10 instance as it allways did flawlessly. When I downgrade the freerdp-package on my main machine to 1:2.0.0_rc4-4 the connection is establishing again. A clean Manjaro installation with the latest updates installed does not connect either.
On two other machines running Netrunner 19.01 Blackbird the rdp connection to the same win10 instance can be established although this info may not be of any help because I can’t compare the freerdp versions due to different labeling.
I checked the freerdp issues section on github and the bugs section on bugs.archlinux.org but could not find anything regarding this issue so it may be a problem starting with manjaro…
Can anybody confirm this issue?

PS: I am with netrunner since dryland and because this ist my first post I’d like to take this opportunity and say a big thank you to you guys offering such a great distro! Keep on running!!!


#2

I think this is worthy of asking in the Manjaro channels aswell. Maybe AJSlye can poke around there if you don’t want to create an account there.


#3

Thank you for your reply, leszek. I will copy and paste the issue in the manjaro forum adding some introducing words.
I know AJSlye is contributing to the manjaro-distro as well but as my capabilities in pushing netrunner forward are limited this is the least I can do…


#4

Sounds to me like a regression in the 1:2.0.0_rc4-6 release.
I’m not sure what if anything Manjaro changed between -4 and -6, but I will check.
However, it could also be an issue with krdc.
Have you tried to see if you could connect using it’s built in clients for X11 or Wayland?

Here is the upstream projects issue tracker, could be something in there your hitting:


#5

I was searching the github issue tracker before but didn’t find anything that comes close to my problem.
As far as I read, the rdp Wayland support is still in beta?
I am not that familiar with all that wayland stuff but trying “wlfreerdp” gets me this output:
failed to connect to Wayland display (null): Datei oder Verzeichnis nicht gefunden

The X11 built-in rdp client, i.e. xfreerdp I assume, is not connecting either.
After entering following command:
xfreerdp /v:10.45.42.112:3389 /u:FA-HYPER-V-Win10

this is the terminal output:

Summary

[20:15:36:737] [14632:14633] [INFO][com.freerdp.client.common.cmdline] - loading channelEx cliprdr
Password:
[20:15:37:761] [14632:14633] [ERROR][com.winpr.sspi.Kerberos] - Failed to convert password
[20:15:37:761] [14632:14633] [INFO][com.winpr.sspi.Kerberos] - Authenticated to Kerberos v5 via login/password
[20:15:37:762] [14632:14633] [ERROR][com.winpr.sspi.Kerberos] - Init GSS security context failed : can’t use Kerberos
[20:15:37:762] [14632:14633] [WARN][com.winpr.sspi] - InitializeSecurityContextA status SEC_E_INTERNAL_ERROR [0x80090304]
[20:15:37:762] [14632:14633] [ERROR][com.freerdp.core.transport] - NLA begin failed
[20:15:37:762] [14632:14633] [ERROR][com.freerdp.core] - freerdp_set_last_error ERRCONNECT_AUTHENTICATION_FAILED [0x00020009]

I configured the rdp-server on the win10 machine to not asking for a password so I don’t have to enter one.

If wlfreerdp and xfreerdp are not the built-in clients you where talking about please let me know.


#6

To be honest I’m not too familiar with rdp, but yes, those were the clients.
Here are the issues I get when searching google for [ERROR][com.winpr.sspi.Kerberos] - Failed to convert password:



#7

Sorry, my fault. I could have used google myself…
Anyway, after setting a password on the win10 machine xfreerdp is working, krdc is working too :grinning:
So the problem seemed to be the missing password on the win10 machine, although this config worked until freerdp 1:2.0.0_rc4-4.
So problem not really solved but for now a solution.
Thanks a lot for your immediate help!