[Solved]: Cannot get NRR 2016.01 Live DVD to boot or install

I have a system disk which is rated “good” by SMART even though it has bad sectors. It has five partitions of which three are to accommodate different distributions, if need be, even though I intend to use only NRR as my routine system with my conventional home directory.

I have been able successfully to install Kubuntu 15.10 and Netrunner 17 in the first two partitions and can boot into either via the grub menu. Booting takes time, but there is no other drama.

However, when I try to install NRR 2016.01 from the DVD (MD5 checksum of ISO checks out and k3b verified the DVD after writing it), I am unable to boot to a Live NRR system or install it. When I press F12 when the Netrunner Logo spins, I get to see a sequence of steps which always hangs with a message like (might not be exact):

Failed to start Live Media MHWD task mhwd script 369 blocked for more than 120 seconds
and the MHWD script simply does not get started even after 15 minutes. Slecting with Safe Settings for the Kernel did not change the outcome.

I then tried NRR 2015.09 and 2015.11 both after a cold reboot. I again got the same behaviour.

The upshot is that I cannot install NRR on my system at present, and I do not think it is a disk, or other hardware, problem because I have two working systems on the other two partitions: Kubuntu 15.10 and Netrunner-17.

How might I get to install NRR 2016.01 from a Live DVD on my machine?

Evidently your selecting non-free mode from the live media if MHWD is running on boot.
I have two questions.
A: what utility did you use to burn the ISO to your USB stick? With these ISO’s you can NOT use unetbootin or similar utilities, these ISO’s need to be written in raw mode.

B: What GPU or GPU’s (Hybrid graphics sub-system) is inside your system?

I selected the first option on the menu: Start Netrunner Rolling. I did not selet the non-free mode because my card is Radeon and there are no non-free drivers for that.

A. I used k3b to burn my DVD using the “burn image” option. I did not have access to any software to write an ISO image to USB in Kubuntu 15.10 or Netrunner-17. I believe that the DVD was written in DAO mode as is usual in k3b.

B. It is an on-board AMD/ATI RS780L [Radeon 3000] Radeon graphics device. No fancy video card on top of that.

Here is an extract from /var/log/gpu-manager.log:

[code]Vendor/Device Id: 1002:9616

BusID “PCI:1@0:5:0”
Is boot vga? yes
Found “/dev/dri/card0”, driven by “radeon”
output 0:
DVID connector
Number of connected outputs for /dev/dri/card0: 1
Skipping “/dev/dri/card0”, driven by “radeon”
Skipping “/dev/dri/card0”, driven by “radeon”
Does it require offloading? no
last cards number = 0
Has amd? yes
Has intel? no
Has nvidia? no
How many cards? 1
The number of cards has changed!
Has the system changed? Yes
main_arch_path x86_64-linux-gnu, other_arch_path i386-linux-gnu
Current alternative: /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf
Current core alternative: (null)[/code]

I cannot rule out some flaky hardware becuse the sysetm response is sluggish and not what I am used to. But I cannot probe further because I do not have access to NRR, which by far seems best suited to my usage.

Did you slow the burning down to it’s lowest level before burning the ISO?

Can you try to burn the iso this way:

growisofs -Z /dev/dvdrw=/path/to/image.iso

I just did that. Here is what I saw when booting from the new DVD:

[at the top] FAILED to start Load Kernel Modules ... [OK messages all the way unitil] A start job is running for LiveMedia MHWD Srcipt (<elapsed time>/no limit) [at the bottom]
After ten minutes of this, I shut down the machine manually.

I will try out the new DVD on another machine tomorrow, but its motherboard and builtin graphics are different.

Can you please, on the boot screen, before choose “Start Nerunner Rolling”
Hit F4 and select “Safe Settings”
And check what gonna happen.

I am not sure whether it was the lowest power level burning when I burned it under k3b.

But I also burned using gericom’s command line prescription and have reported those results. Should I try anything else besides?

As an alternative, is there any program that i can install in Netrunner-17 that can burn an ISO onto a USB drive?


not the easiest, but the most sure way is

dd bs=4M if=/path/to/your.iso of=/dev/sdX status=progress && sync

Where sdX is your flash drive

I already did that as reported in my original post. I have not done it with the new DVD burned using the command line, but I suspect that there will be no change.

The Suse studio Imagewriter may be available under Ubuntu, If not I’ve been successful using Disks restore image method as well.

Apparently, ‘progress’ is not a valid status flag; ‘noxfer’ and ‘none’ are.

But more importantly, I am denied permission to write to /dev/sdc1 which has a ‘nosuid’ option when I type ‘mount’. I do not want to brick my flash drive. So, I will explore other alternatives before proceeding further.

Then let’s remove this flag and execute it as root
sudo [size=small]dd bs=4M if=/path/to/your.iso of=/dev/sdX [/size]

You can’t write to a partition, it needs to be the whole drive:

dd bs=4M if=/path/to/your.iso of=/dev/sdc status=progress && sync

Notice that the 1 is missing from here /dev/sdc1

I did

sudo dd bs=4M if=/path/to/your.iso of=/dev/sdc && sync

and booted from the USB. It was fast! But it still hung on the MHWD Script for more than twelve minutes before I decided to tturn it off. This time, the info message included:

[INFO]: task mhwd:509 blocked for more than 120 seconds

I will later try it out with the Safe Settings for Kernel and still later on another machine, where I hope it will work.

What sort of hardware problems will result in such behaviour as I am seeing?

EDIT: 1. Even with Safe Settings for the Kernel, it still does not boot. 2. The USB drive boots fast and perfectly on another PC. So, I do not think there is any problem with the media. 3. Conclusion: my PC hardware is flaky and needs to be replaced. Kindly advise me if you think it is otherwise, or if you have a workaround.

Thanks for all your help.

The problem has been solved and I am sorry for raising a false alarm.

I have a Transcend USB 3.0 Expansion card that requires a power supply via a Molex connector. In the process of swapping hard drives, I had disconnected, but later neglected to reconnect, that Molex connector. So that one card sitting on the PCI 1e slot, without a power connection, had been causing the perplexing problems that I had been encountering. Once power supply was restored to that card, I could boot NRR 2016-01 without incident to install the new system.

Kudos to NRR Live for detecting a hardware flub that whizzed past the other installers.

Thanks also to AJSlye and gericom for educating me yet again. :slight_smile: