[Solved] Can't boot After update

After the update on january 17, my computer (Schencker XMG a501, Intel Core i7-2630QM, NVIDIA GeForce GT 540M, NVDIA optimus) won’t boot any more. The computer comes to the point where it says :

[ok] started login service.outh … boot screen to quit.

Then it hangs.

How do I solve the issue?

I can not also log in in a virtual TTY and start x. That is ctrl [strg] + alt + F2 --> then startx is not working, because I can not login. No matter what, after entering the login data, the computer jumps back to an empty screen, again with the login prompt. That is, it does not tell me that the login failed, but instead refreshes itself, and clears the screen, and at the very top showes a fresh new login prompt.

That was for 3.14 kernel and it’s fallback image. If I use the 3.17 kernel, it hangs at “Starting wait for Plymouth boot screen to quit” (same for 3.17 fallback)
I dont want to install every single software I installed so far once again from scratch …

This sounds like the graphics drivers, what drivers were you using prior to the update?
Bumblebee with Intel-Nouveau or Intel/Nvidia

You won’t need to re-install anything as long as you may can still chroot into your system from the live media and fix it.

Bumblebee with Nouveau

So it’s starts up using the Intel drivers then, I would chroot in to your system and re-run the update, it sounds like it may have failed or was incomplete.

I got iside using a live CD

Now for CHroot, I do this : https://wiki.archlinux.org/index.php/change_root

And how do i +re_run+ the update? Pacman obviously has no way to reupdate everything now, as even the broken softwares are of the latest version?

If you chrooted properly your now using your installed system so you would run the command just like you normally would. However, I would run ‘sudo pacman-mirrors -g’ first.

I would also since your chrooted check that all of the drivers are installed and setup properly with mhwd.

I cannot find bash in the chrooted system. This is strange.

pacman-mirrors -g just keep on saying could not resolve host.
[hr]
Done, it is however not updating. There is nothing left to do

If bash didn’t update properly than there’s your problem.
Did you preform the bash security update from the readme, before running the update-pack?

Here is what to do once chrooted, just to be sure:

sudo pacman-mirrors -g
sudo pacman -Syy
sudo rm -R /var/lib/pacman/local/bash-4.3.024-1
sudo pacman -S manjaro-system pacman
sudo pacman -Su

I would also recommend updating your 3.17 kernel to 3.18 once your able to boot into your system normally.

Okey, solved. This is How i did it.

I have chrooted to my system as given here : https://wiki.archlinux.org/index.php/change_root . However, chroot /mnt/netrunner /bin/bash (or /usr/bin/bash) failed, saying it was not found. I then used chroot /mnt/netrunner /bin/fish. Luckily I have fish installed. (I had bash installed though, so I don’t quite understand - the only thing wrong with bash was an warning that there was a double entry “bash” - I ignored it during update)

However, with fish, pacman-db-upgrade does not work, it needs bash, as the fish syntax is slightly different. I did not want to go into correcting it all.

I decided to use pacman -Suu and / or pacman -Syu - either won’t work, with the error, couldn’t resolve hostname - so I edited /etc/resolv.conf, and added nameserver 8.8.8.8 there. See : https://bbs.archlinux.org/viewtopic.php?id=138412

Then I reinstalled bash, then I reinstalled bumblebee.

This works now. (I am just seeing your answer by the way … :stuck_out_tongue: - but very kind of you to answer in the dead of the night)

Actually since I’m in Florida it really isn’t all that late, only about 9:45 pm right now.

I’m glad you got it solved however. :slight_smile:

Ah, yes. I am on the other side of the Ocean.
[hr]
Also, kernel updated to 318.

I’m just glad I was able to point you in the right direction. :slight_smile: