Netrunner Home

[Solved] Can't install nvidia driver on Maui


#1

Hello people,
recently I bought a new computer and installed Maui on it.
I need to install the nvidia driver for my gtx970 graphic card but I wasn’t able to do it.

  • I downloaded the driver NVIDIA-Linux-x86_64-343.22.run from the nvidia web site
  • I followed the instructions:
    Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./NVIDIA-Linux-x86_64-343.22.run
    But I always get this message:
    The distribution-provided pre-install script failed! Are you sure you want to
    continue?
  • I also sent the driver nouveau to the blacklist but it didn’t work

I tried out of the X server (Ctrl+ALT+F1) but I get the same message

How can I Install this driver on Maui?

Thank you!
Jair


#2

There is no need to install the nvidia drivers manually.
As long as you ran the latest set of updates on your system, the driver manager is back and available under System Settings for you to use.


#3

I ran the update of my system and I got no driver manager on my system settings :frowning:
I know in the last netrunner 17 was really easy to do it, but I don’t get this option here in Maui after the update.


#4

Strange, It should have been added under the hardware section of system settings after the update.
Did you reboot after the update?
Were there any updates that were not applied?
Usually, level 4 or 5 in update manager.
If so, what are they?


#5

Yes, I have reboot several times today :smiley:
there is no update in update manager… “your system is to date”
on system settings I see only “network drives” and “windows wireless drivers”


#6

Even stranger, this is what system settings should look like:
[attachment=1007]

Can you post a screenshot of what your getting?


#7


#8

Hmm, looks like it wasn’t installed with the update like it should have.
Open update manager and make sure there are no held back packages that could be causing this issue.


#9

I did it… I refresh and refresh again and it is always up to date. I can’t see any back packages left.


#10

Then try manually installing kubuntu-driver-manager and it should appear in systemsettings.


#11

It worked fine! Now I got nvidia dirver installed
Thanks


#12

Nice that it works now