[Solved]: Dropbox suddenly does not start

Dropbox, which was working fine, suddenly does not start and the icon does not appear on the system tray.

The following error message text file is output with the invocation dropbox --help:

[code][get_extra_trace_info failed]
Traceback (most recent call last):
File “dropbox/client/main.py”, line 614, in boot_error
File “dropbox/client/main.py”, line 3758, in get_dropbox_path
AttributeError: ‘NoneType’ object has no attribute ‘local_config’

Original traceback:

Traceback (most recent call last):
File “dropbox/client/main.py”, line 4065, in main_startup
File “dropbox/client/main.py”, line 1788, in run
File “dropbox/client/main.py”, line 764, in startup_low
File “dropbox/client/main.py”, line 696, in _parse_command_line_flags
File “getopt.py”, line 88, in getopt
File “getopt.py”, line 152, in do_longs
File “getopt.py”, line 169, in long_has_args
GetoptError: option --help not recognized[/code]
An error message box also appears as shown in the attached screenshot, which suggests a permission problem. I have already tried the remedies suggested at the Arch Dropbox wiki without a solution. I have specifically recursively changed ownerships of the folders ~/Dropbox and ~/.dropbox with $USER:users.

It bears noting that starting dropbox from a terminal results in the output so:


If this forum is not the right one for this issue, kindly let me know where to post or search for a solution. Otherwise, thanks for your help in advance.

Sorry I can’t help, but you are not alone. I have same problem: “Killed” Fortunately, I don’t really use dropbox that much anymore.

Actually, that looks more like a python and/or a metadata related issue to me .
Have you tried asking dropbox support?

I had a different error after the last update that caused dropbox to not run:

$ dropbox Traceback (most recent call last): File "dropbox/client/main.py", line 38, in <module> File "dropbox/client/aggregation.py", line 15, in <module> File "dropbox/sqlite3_helpers.py", line 27, in <module> File "dropbox/fatal_db_exception.py", line 2, in <module> File "arch/__init__.py", line 27, in <module> File "arch/linux/util.py", line 27, in <module> File "arch/posix_common/util.py", line 16, in <module> File "dropbox/gui.py", line 13, in <module> File "dropbox/threadutils.py", line 16, in <module> File "dropbox/sync_engine/sync_engine_util.py", line 17, in <module> File "librsyncffi/api.py", line 12, in <module> File "librsyncffi/compiled/_librsyncffi.py", line 14, in <module> ImportError: librsync.so.1: cannot open shared object file: No such file or directory
However, reinstalling dropbox fixed this issue for me and dropbox is now working just fine.

May I also ask, are you using the dropbox package from the Manjaro repositories, or are you using one from the AUR?

I tried removing and re-installing dropbox and found no change in behaviour.

Also, I believe that the dropbox I am using comes from the Manjaro repositories. It was available pre-installed when I did a fresh install and upgrade. Also, I get:

pacman -Qen | grep dropbox dropbox 3.12.6-1
So, I trust that it is from the Manjaro repositories.

I have also reported this in the Dropbox Forum under this thread started by another user.

Just as suddenly, the Dropbox icon started showing up in my system tray again. And I am thankful for small mercies! Although it would surely help to understand why it happened as well!

I will wait for a few days before I mark this thread solved, just to be sure.

EDIT: Ouch! After about eight hours, and two reboots after X-server crashes, I have lost the Dropbox icon on my system tray as well as synchronization. I wonder what is going on.

There is a simple, if inconvenient, temporary workaround given by Mark F.

None of the other solutions given at that site seem to work for me.

Let’s try something different :slight_smile:
Do these in terminal

Step 1. Kill dropbox

killall dropbox

Step 2. We gonna move the old dirs to be able to recreate new ones

mv ~/.dropbox ~/.dropbox.old mv ~/.dropbox-dist ~/.dropbox-dist.old
Step 3. Restart dropbox again and voila, it is working and has UGLY icon :smiley:

AFAICT, you need to do this each time. Logging in after a poweroff, you have to repeat the above steps to see the Dropbox icon and whether your files are synchronized. So, it is swings and roundabouts: login/logout/login again or execute the sequence you have given. Alas, there seems to be no clean and convenient solution.

Try checking the permissions on your dropbox folders:

Uninstalling and re-installing dropbox has also fixed this for some other users.

I have done

sudo chown -R $USER:$USER $HOME/Dropbox $HOME/.dropbox $HOME/.dropbox-dist


sudo pacman -R dropbox sudo pacman -S dropbox
Starting dropbox after that still gives me the “Killed” message that I first reported.

I wonder what happens between a first login and a second to enable the system tray icon to appear after the second login but not the first.

Is enable dropbox to run on Log in?

KDE usually does this for you, but doesn’t always depending on the desktop session settings:
System Settings > Startup And Shutdown > Desktp Session > On Login > Restore Previous Session.
I believe the default is now Start with an empty session, which would cause the issue your describing.

Another option would be to add a dropbox.desktop file under ~/.config/autostart.

You can also set it to run at startup or login using systemd.

Please see attached screenshots for KDEand dropbox startup preferences.

The contents of ~/.config/autostart/dropbox.desktop are:

[code][Desktop Entry]

GenericName=Network Storage
Comment=Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily
where I am a little concerned about the meaning of the last line. Could it be the cause of the icon disappearing?

I have also followed, as best I could, the systemd instructions to enable dropbox.

None of the above could restore the icon.

But a login followed by a logout and another login does. Shame! I do not know why.

Having more than one way to start up dropbox may be your issue, you’ll need to select to use either a .desktop file, the Restore Previous Session setting under system settings, systemd, or the setting in the application itself.

The line StartupNotify line tells the desktop (Plasma) whether or not to use whatever startup notification is built in to either your application or your toolkit, by setting this to false it is disabling the notifications.

I did not select the KDE startup checkbox. Nor did I select the dropbox startup checkbox. Both were pre-selected for me and I trust that this was how the packages were bundled. The systemd methods were not set and I might remove them after reading your reply (if only I knew where to look as systemd files seem to have UUID type suffixes!). The systemd methodology is something I need time to learn to grapple with.

Don’t mess with the systemd files unless you have to, just enable or disable the units using systemctl like this:

sudo systemctl dissable dropbox.service

The unit names are also easy to understand for the most part.

More on using Systemd:

I followed the instruction at automatically starting Dropbox.

The only change I think I have from a standard system is the file ~/.config/systemd/user/dropbox.service.d/override.conf which as the lines:



The other files associated with dropbox in the systemd tree are /usr/lib/systemd/system/dropbox@.service and /usr/lib/systemd/user/dropbox.service. The latter is:



ExecReload=/bin/kill -HUP $MAINPID

I think the other files are all installed by default.

Please advise if any of these modified files need to be removed.


This seems to be an issue with the latest code from dropbox.
However, there is a temporary solution until this bug is found and the code gets fixed.

Create a file in your ~/.config/autostart-scripts/ folder named dropbox-fix.sh and add these lines to it:

#!/bin/bash dropbox stop dbus-launch dropbox start
Then make it executable:

chmod 0755 dropbox-fix.sh

This will show up under System Settings > Startup and Shutdown > Autostart > Script File.

Please thank Kirek from the Manjaro core team for this temporary solution.
Reference: https://forum.manjaro.org/index.php?topic=31095.msg261234#msg261234

I have removed the file ~/.config/systemd/user/dropbox.service.d/override.conf, and inserted in its stead this script to be executed at startup.

I can confirm that it works and there is no more need to do the login/logout/login routine any more. The Dropbox icon does show up on the system tray on login.

I shall provide a link to the solution at the Manjaro form at the Dropbox forum.