back to Netrunner | back to Blue Systems

(SOLVED) Epson ES-400 Scanner


#1

I’m using Netrunner Rolling on my laptop (love it)…but I have one issue. I cannot get it to find my Epson ES-400 scanner. It is plugged in directly via USB and I have installed the following packages:

Image Scan!
iscan-data
iscan-plugin-gt-s650
iscan-plugin-gt-x820
iscan-plugin-network

Has anyone else run into this problem?


#2

Looks like that scanner requires imagescan (aka iscan3 - 3.57.0)…
After searching epson for your model I ended up here:
http://support.epson.net/linux/en/imagescanv3.php

These packages listed bellow are only for iscan (aka iscan2 - 2.30.3), not imagescan.:

iscan-data
iscan-plugin-gt-s650
iscan-plugin-gt-x820
iscan-plugin-network

Remove all iscan packages, and then install imagescan.


#3

Thank you AJSlye. I removed the iscan packages and installed imagescan. However, my system still does not detect the scanner. Any other suggestions?


#4

No, I haven’t tried scanning into my computers using any of my networked Epson all in ones, I tend to use my commercial grade brother laser all in one for that. It has a much better quality than any consumer grade product i’ve had. With that said, I may give it a whirl at some point this week.


#5

Okay. Thanks.
I don’t know if it makes a difference but the ES-400 is only a scanner, not an all-in-one.


#6

Yes, I know that. And yes, it should use the utsushi backend (imagescan 3).
http://www.sane-project.org/lists/sane-backends-external.html#S-UTSUSHI
https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#Image_Scan_v3

Have you tried a different usb port, or even rebooting after pluging it in?

These two issues may also be plaguing you:
https://wiki.archlinux.org/index.php/SANE#Multiple_backends_claim_scanner
https://wiki.archlinux.org/index.php/SANE#Communication_via_xHCI_not_working_(older_scanner_models)


#7

That’s it. After installation I searched my apps for UTSUSHI and clicked on RUN UTSUSHI. Viola! I’m in business.
Thank you very much AJSlye!!