(SOLVED) Ethernet Connection -deactivated

Was using Netrunner Debian with no problems. Switched to Arch based Netrunner cannot connect via ethernet connection. Error message IP configuration was unavailable. I am connected to my router and the web. Anyone know what the problem could be. thank you.

Never mind it was the conflict between RTL 8168/8169.

I was going to suggest removing the 3rd party 8168 driver. There was a time when the 8168 driver was needed, but lately the kernels own built in 8169 driver has been on par, if not better, then the one from realtek at supporting more hardware. This, and the fact that our in house tests show that mhwd doesn’t even load, or activate the 8168 driver in live mode despite it being installed. However, calamares does active this driver on the installed system during the mhwd setup phase, causing issues where they didn’t exists in live mode. There is an ongoing discussion between the Manjaro maintainers and the kernel/mhwd developers on removing this driver.

Thank you for your response. It seems that overnight the 8168 problem returned. Please advise me how to remove the 8168 and install the 8169 driver. Currently the 8168 driver installed is the linux419-rt-r8168.

Thank you.

sudo pacman -R linux419-rt-r8168

The r8169 driver is already installed as part of the kernel package itself.

May I ask why your using the realtime kernel?

Sure my limited knowledge and using what is available via the basic installation. I ran into the same problem with my arch bluestar setup and instead of changing drivers I just purchased a new non realtek NIC card. But any advice you may have is welcome.

We don’t ship the rt kernel though, this is why I asked.

Ok so what is your suggesttion for using 8169.

I already answered this, I even gave you the command to use to remove the 3rd party driver (kernel module).
Unless you have the r8169 driver blacklisted for some reason, removing the 3rd party r8168 driver is all that is needed. Well besides a reboot that is.

Great thank you for the help

FWIW with a fresh install of NR rolling my r8169 eth was working fine. I upgraded to the 5.2 kernel, rebooted and no eth. I finally poked around in /etc and found that the r8169 driver was blacklisted. I did not blacklist it, all I did was change to the 5.2 kernel and something in that package update decided to add the driver to my blacklisted modules.

Yes, when the r8168 driver is installed, the r8169 gets blacklisted. There has been many discussions on the third party r8168 issues in the Manjaro forums, both public, and in the private maintainers area.

You could also have been using the r8168 driver (default) prior to the update, and found a bug between it, and the 5.2 kernel. You can check this by running inxi -n in a terminal window.

PS. This thread was marked solved, please create an new thread next time.