[Solved] Firefox KDE integration

The KDE upload dialog is not working for me on Firefox.

Can you paste the exact firefox version as under “About”?

“Firefox 22.0
Mozilla Firefox for Netrunner
netrunner - 1.0”
Packpage version 22.0+build2-0ubuntu0.13.04.2 according to Synaptic.

Tried to reinstall firefox-kde-support through Synaptic(it didn’t solve the problem) and got some strange output:

debconf: unable to initialize frontend: Gnome debconf: (Can't locate Gtk2.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 91, <> line 1.) debconf: falling back to frontend: Dialog (Reading database ... 177270 files and directories currently installed.) Preparing to replace firefox-kde-support 0.6.4~git20130318+5-0ubuntu0~ppa5~raring1 (using .../firefox-kde-support_0.6.4~git20130318+5-0ubuntu0~ppa5~raring1_amd64.deb) ... Unpacking replacement firefox-kde-support ... Setting up firefox-kde-support (0.6.4~git20130318+5-0ubuntu0~ppa5~raring1) ...

Seems you updated firefox to v22, where Netrunner 13.06 ships v21 default, as that’s the only one currently working with the firefox-kde patch.
If you update firefox from ubuntu, it’s not properly patched against firefox-kde.

Thats it, thank you. :smiley:
After uninstalling Firefox then reinstalling again it worked(and now it is 21.0). I wonder if the version 22.0 came with the dist-upgrade…