(Solved) Firefox Plasma ppa

edited by starbuck: To clarify the latest updates, please see this post: http://www.netrunner-os.com/firefox-and-thunderbird-plasmified/

Hello Netrunners,

just updated to the recent version 14.1. The update works good, no problems at all. At the Netrunner main-site I’ve read about the the new firefox-plasma ppa. I move to these site and install the ppa as shown there. Finally I’m not able to install the firefox-plasma because the lack of the Firefox 35 at the system (currently running Firefox 34 from the official ppa). The ppa has the Firefox 35 prebuild inside but I don’t know why he not install.

Firefox 35.x is already in the Netrunner/Kubuntu repositories, as is firefox-kde-support 6.4.
If you wish to use the packages from the firefox-plasma ppa then you’ll need to move it up to the top of your sources.list file.

My system is up to date (sudo apt-get update && sudo apt-get upgrade done again after I did all this) but I too still only have Firefox 34.0.

I checked my /etc/apt/sources.list.d/official-package-repositories.list matches the one at https://github.com/netrunner/netrunner-apt-config/blob/frontier-14/etc/apt/sources.list.d/official-package-repositories.list [size=x-small]…expect lines 4 and 5 are reversed - shouldn’t matter correct ?[/size]

Confused again… :slight_smile: Thanks!

I apologize, it’s actually in the Ubuntu repositories, but you should still have it already:

Could you please try this:

sudo apt-get update
sudo apt-get upgrade firefox

Upgrading said “firefox is already the newest version.”
I tried to reinstall (sudo apt-get install --reinstall firefox) and it reinstalled 34.0 again.

If I do this I do see a version 35.0 listed…

[code]~$ apt-cache policy firefox

Installed: 34.0+build2-0ubuntu0.14.04.2~ppa2~trusty1
Candidate: 34.0+build2-0ubuntu0.14.04.2~ppa2~trusty1
Version table:
35.0.1+build1-0ubuntu0.14.04.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
*** 34.0+build2-0ubuntu0.14.04.2~ppa2~trusty1 0
700 http://ppa.launchpad.net/netrunner-os/frontier-14/ubuntu/ trusty/main amd64 Packages
100 /var/lib/dpkg/status
28.0+build2-0ubuntu2 0
500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

… so in synaptic I selected firefox and used package >>> force version and was able to select 35.0.1 from the dropdown and now I have 35.0.1. I can’t figure out why I would I haved to force the upgrade, though.

and… Sorry I didn’t intend to highjack thread, but it seemed related to play’s original post.

Thank you for all these answers. The official ppa’s given me only the Firefox 34 so I install the Firefox 35 manually from the firefox-plasma ppa and it works! Then I install the matching language package from the firefox-plasma ppa and it works also. So my problem is solves.

Just as a reference.
The frontier-14 ppa by default has a higher priority set so it won’t automatically upgrade to any newer version of any ppa if this ppa has a minor priority.

Though for this particular case you could run

sudo apt-get install firefox=35.0.1+build1-0ubuntu0.14.04.1

(The version number was taken from your apt-cache policy post).
It will then grep the version from the Firefox Plasma ppa and will stay on that so that future updates will keep downloading from there. (and only if the strange thing might happen frontier-14 ppa has a higher version number then the one in firefox plasma ppa it would grab that)

Leszek as you can see from my post earlier and from the following link:
Firefox 35 is already in all of the official Ubuntu repositories.

Chatan updated firefox by forcing it to install from the official repositories, not the firefox-plasma ppa.

Playforvoices is the one that used the firefox-plasma ppa, which is no longer needed.

Ah ok. My mistake.
But note: Firefox 35 in Ubuntu Repos comes without the kde integration

OK, my mistake then.
I had thought that was what the firefox-kde-support package in the Netrunner PPA repository was for:

yes, the Firefox from the officially ppa is simply a Firefox without integration. So the firefox-plasma ppa is a good choice for a KDE user. Hope the system will update the Firefox now from these repository and not from the official ppa.

I was confused by the firefox-kde-support package in the Netrunner PPA repository, again I do apologize.

Also keep in mind that in the Netrunner Rolling (Manjaro) edition we already have the firefox-kde and thunderbird-kde packages in the official repositories, besides even if they weren’t we have the AUR for this kind of thing. :slight_smile:

To clarify the latest update, please see this post:

Thanks for the post at the main page. Now Firefox and Thunderbird are working perfectly with the new plasma-ppa. :wink:

I’m happy the new packages are working for you.
Could you do us a favor and put (solved) at the beginning of your original post’s thread title.
Thanks in advance.