[solved] Firefox strange behaviour

Hi there, it’s me again :angel:. Within the last days or a couple of weeks i note a strange thing with Firefox. When I logout or suspend and then return to the system, Firefox restores the former session, but then just doesn’t react on various things. Writing to the address line makes it always only write one letter “over” the other, the contest menu does not work, carpets in the bookmark bar won’t open, the little sign for minimize, maximize and quit disappear … The only way to correct this behaviour is to totally restart the system. I wonder if anyone has any idea or something similar occurring.
Thanks for spending your time with a noob like me :s

P.D: Reading a lot in internet and trying to solve the problem, I understand that this version of Firefox from repo cannot be replaced by Firefox 36.

So the window decoration is gone sometimes? On all windows I guess.
Sounds to me like a graphicsdriver issue. Do you have proprietary drivers installed? Do you have desktopeffects enabled?
Can you try looking if it works with disabled desktopeffects.
Maybe hardware acceleration needs to be turned off in firefox aswell.

Hello leszek!

Thanks for your answer! I have tried all that i could form the thread you left a link, but nothing. Also, this thread is only about Firefox, so, when i restore a session from suspend, ALL programs stop to work, as i said. Maybe you could tell a noob what you mean with desktop effects?! Do you refer to p.e. cube animation …
Yes, i finally managed that cube animation works, but i don’t think that has got something to do with it, since in Mint Rebecca KDE it works flawlessly :huh:
Thanks again for spending your time and maybe you have another idea. Until that, i think i can live with it :-/


What exactly do you mean by that?
Have you already tried updating firefox-plasma to 36.0.1?

Where and how?


If you are using netrunner-15, you should have the moz-plasma ppa added default, so
“sudo apt-get update” and “sudo apt-get install firefox-plasma” should do the trick.

Thanks a lot! Updated and worked all day. So I’ĺl see tomorrow … :slight_smile: