back to Netrunner | back to Blue Systems

(SOLVED) Gimp plugin dying for pdf's


#1

Hello
I hope that someone can tell me where to go,
had not used import pdf into gimp for a few months with all the other things going on,
went to import a pdf and got this

Screenshot_1502

Has anyone else had this happen ?,

Is there anything that can be done so as to import pdf s into gimp ?

I’ve looked about and it seems that not many are using this option, shame really it’s a good tool, so anyway if anyone knows of a way to bring it back to life ? ( if possible ) or is it DED .
If you could help , please post a reply as I need some help with this one,

Thanks in advance


#2

Is this on Debian, or on Manjaro?
Have you tried other pdf files?
I only ask because I can import pdf’s directly from the open dialog into gimp on my system.


#3

Sorry should have said
This is on Manjaro (NRR), are you on NRR?
Ihave tried other pdf s
forgot to mention the pdf s they do open with Okular and Libre office
Why the plugin is dying is strange as there is no talk about that in other forums, Manjaro, Gimp Users, Gimp Forum
Is it dying only on my system only and if so why would that be happening ( no need to answer that just thinking as I type )
Importing into Gimp was never a problem before I went for a road trip, Damn the Holiday,
The plugin dying ( Gimps words not mine ) is a real issue and I’m not sure as to what could fix this is it my install ( verified download ) so that should be OK,
Should I maybe Oh-No - Delete Gimp completely including config folder and then reinstall Gimp, Bit drastic ?
Any suggestion as a way of getting this thing working again will be most appreciated,

Many thanks AJSlye and anyone else also Thanks


#4

Yes I’m on rolling, I’m the maintainer of rolling.
Did you install any external plugins, maybe from the AUR?
If so, one of them might be the cause.

On my system, I do not get that warning message at all.
However, I rarely use gimp, and have no 3rd party, or extra, plugins installed.


#5

Oh had not though about AUR plugins I do have a few extra plugins from AUR installed, I did have those extras installed before ( from the start almost ) and caused no problems so maybe it was an update on the plugins that caused the Dying of plugin,


#6

when time permits I will get back to this and uninstall the AUR plugins all at once
then check to see if loading pdf works IF IT IS working so then
then install one just one plugin at a time and check loading of pdf until I might find the culprit,
after all that is done I’ll let you here know how it all went,
that wont be for a few days have other things that really need to get done (in the real world)
Could have been an update for plugins take did this um sounds possible (ha anything is possible)

So what do you reckon reasonable Idea

edit, Just had a quick look not uninstall yet
Got two extra Plugins
1 - Gmic
2 - resynthesizer
Either one of those two could have had updates and be the problem


#7

Found three extra plugins thanks to Pamac
1-Gmic
2-Resynthesizer
3-Ofnuts-tools ( Gimp forum )
uninstalled all three - still could not load pdf,
found remnants of Gmic delete that - still could not load pdf
uninstall Gimp inc all hidden files I could find,
reinstall gimp
Gimp now loads pdf
reinstall Resyn and pdf loads
reinstall Gmic and pdf loads
force update of Gmic filters ( honestly thought this was the one ) loads pdf
reinstall ofnuts-tools and pdf loads
after every reinstall I rebooted the system, why ? why not refresh things a bit yes overdone eh,
This is where the end result is a ‘one of those things that happen’
and it still loading pdf,

Thank you AJSlye for the reminder about plugins

What do I mark this as ( solved sorted out or still confused ) or all ?


#8

That’s OK, these things happen.
You probably just had some setting that was messed up.

PS. I moved this to the Netrunner Rolling category and marked it as solved for you.


#9

Thank you AJSlye for doing that marking as solved
I appreciate you taking the time to help
Gimp has given its fair share of ‘hiccups’ have to expect that sort of thing when Wilber’s evolves so quickly these days,
Thanks