back to Netrunner | back to Blue Systems

(SOLVED) Help! My system freezes for no apparent reason!


#1

Hey, I’m having problems with my Netrunner Rolling 19.04: on every boot, any time from the moment I get to at least the desktop – sometimes just after punching in my login credentials at the SDDM prompt, sometimes I can get 10 minutes of usable desktop time – my system appears to seize, with all video seemingly frozen, though the hard disk light still blinks as if the system were operating normally. I’m hoping it’s just a problem with the non-free video drivers – I have two 1GB GDDR5 NVIDIA GTX 550 Ti, and from experience I think these cards are restricted to the 390 release of the nVidia drivers. At any rate I’ve been able to run the MHWD and it’s confirmed I’m using the 390 release.

Does anyone have any suggestions for tracing this problem to its source? Thanks in advance for any guidance anyone can offer.


#2

Not certain it’s related, but I’ve tried disabling File Search; that seems to have helped. Since making this change an hour ago I haven’t encountered any further system lock ups. Is that a known problem?


#3

Was this before or after updating the system after install?


#4

This was after I’d installed Netrunner 19.04 – though that raises another problem (about which more in a moment). Since disabling file search on my system it looks like things are more stable – I’ve encountered no further crashes.

I’m still having problems upgrading. I get a prompt to update archlinux-keyring-20190827-1 – and respond “Yes”. I then get:

error: archlinux-keyring: signature from "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" is unknown trust.
:: File /var/cache/pacman/pkg/archlinux-keyring-20190827-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

Choosing the default answer allows me to proceed, whereupon I’m prompted to replace libmagick with extra/libmagick and mhwd-nvidia with core/mhwd-nvidia-430xx (to which I answer NO). Then I’m prompted to remove gtk3 in favor of gtk3-classic (default: NO).

At this point the entire transaction is rejected for unresolvable package conflicts.

Any guidance for getting past this upgrade problem? Thanks again.


#5

Answer yes to both of those, the libmagick package has moved, and the mhwd-nvidia package no longer exist.
It was decided to include the version numbers in all mhwd-nvidia driver packages including the latest (435.xx).

[xxxx@xxxxx ~]$ pacman -Ss mhwd-nvidia
core/mhwd-nvidia-340xx 340.107-1 [installed]
   MHWD module-ids for nvidia 340.107
core/mhwd-nvidia-390xx 390.129-1 [installed]
   MHWD module-ids for nvidia 390.129
core/mhwd-nvidia-418xx 418.88-1 [installed]
   MHWD module-ids for nvidia-418xx 418.88
core/mhwd-nvidia-430xx 430.40-1 [installed]
   MHWD module-ids for nvidia-430xx 430.40
core/mhwd-nvidia-435xx 435.21-1 [installed]
   MHWD module-ids for nvidia 435.21

We ship with gtk3-classic, I’m not sure how yours changed to upstream gtk3.

As far a freezing, it sounds more like an I/O issue where the search is taking up more resources than are available, thus slowing down or suspending other things. Intel chip-sets are notorious for doing this.


#6

I have separate partitions I dedicate to /home and /var, and I try not to overwrite these whenever I make major upgrades. I’ve been running Netrunner for a few years now, upgrading across the Rolling editions; maybe gtk3 was used in an earlier release?

At any rate, I’ve reinstalled 19.04 Rolling again from DVD – my efforts to clear up my keyring issues appear to have completely borked my /usr/bin folder. Now that 19.04 is installed, I still cannot upgrade. I’m getting errors stating I’ve got corrupted packages for lib32-nvidia-390xx*, and signatures for Helmut Stult that are “marginal trust”. The entire upgrade fails due to invalid or corrupted packages.

Should I merely back up the bits of /var that I need to keep, then re-install 19.04 Rolling & reformat & erase / and /var? I’m wondering if I don’t have some cruft leftover from prior installs of Rolling.

Thanks in advance.


#7

Keeping and sharing home and var is usually problematic, especially when using completely different distributions on the same machine. Backwards compatibility across different versions of programs and applications, and there settings, are not always maintained upstream.

I find it best to make weekly or monthy backups of all my personal files just in case of a tragedy (like if my hard drive dies).


#8

OK, I’ve completely reinstalled 19.04 Rolling and have recovered my /var & /home from backup. I’ve experienced no further crashes to date, and things are working well.

Thanks again for the assistance!