[Solved]: HP PSC 1310 series scanner is not recognized by sane

I used to be able to scan images using an HP 1310 series printer/scanner/copier and xsane in the past, when I was running Kubuntu. Now, on NRR, after connecting the device, xsane does not seem to recognize the device. Neither does Skanlite.

hp-setup recognizes the device, though, and can set up the printer function.

Following the advice at the Arch wiki for SANE I tried

scanimage -L

only to get

No scanners were identified. If you were expecting something different, check that the scanner is plugged in, turned on and detected by the sane-find-scanner tool (if appropriate). Please read the documentation which came with this software (README, FAQ, manpages).
What exactly is the sane-find-scanner tool?

I have tried switching the device off and on again, to no better effect. Also, it is recognized by KInfoCenter as a connected USB 2.0 device so:

Vendor ID 0x3f0 (Hewlett-Packard) Product ID 0x3f11 (PSC-1315/PSC-1317)
The HP multifunction device I am using is an established model that was recognized by and worked with xsane in the past. Any help getting it to work again is most appreciated.

Did you try installing your HP 1310 using hplip?

Thanks for that SANE link. For the record, here is what I did for my particular device:

  1. I uncommented the last line in

which was

  1. I deleted previous printers and ran hp-setup as myself, not root.

  2. I ran hp-plugin and allowed installation of the plugin.

  3. I ran

sudo pacman -S python-pillow
  1. I ran hp-scan and got the scanner working from the command line.

  2. I tried xsane, and the scanner is recognized and works as a scanner!

Thanks, AJSlye.

I’m glad to hear that you got it working, just one note:

That printer doesn’t require a proprietary firmware plugin, that step can be skiped in the future.

Thanks. I will check if a plugin is needed if I have to do this again with another HP scanner.