[SOLVED] Installation problem

Hi all:

I really didn’t want my first post on this forum to be a problem report, but I guess that’s how it goes. I’ve been looking for a Linux distro to settle on for several months, heard and read a lot about Netrunner, so I downloaded both flavors a couple of days ago. My primary interest is in the rolling release version, so I tried that first on my test system.

It’s a Dell Inspiron with 6GB of ram, and a 500GB HD, about 150GB for Windows 8.1, and the rest for Linux, in two main partitions. The Linux partition has these partitions:

/boot: (500MB)
/: (20GB)
swap: (4GB)
/home: (the rest)

I’m by no means a Linux expert, this scheme was recommended to me by a friend as a way to rapidly install Lunix distros without messing up my Windows boot sector. I use EasyBCD to handle dual booting the system. I have installed at least 15 distros this way without incident, pointing BCD to sda3, which is the Linux boot partition. Netrunner rolling is the first distro I have tried that put grub in the Windows boot sector in spite of what I told it to do.

I always use manual set-up, and since I don’t have to make the partitions each time, merely “change” them, it goes quite quickly. I always tell the installer to put the boot in sda3. Netrunner rolling has a warning on the selector that installing the boot anyplace other than sda1 was “not recommended.” I ignored that, and proceeded. When the installation started, I got a warning message, something about formatting, but it made no sense, and had no option other than to close it. When the installation finished, I rebooted, and was greeted with grub in the Windows boot sector. Windows was an option, and when I chose it, I was presented with the EasyBCD menu.

I went into Netrunner and let it update, using the instructions in this forum. It worked wonderfully well, and so did the system, so far as I could tell. I tried several ways to restore my boot sector with some of my tools, but nothing worked short of reinstalling Windows. I installed Windows 7 this time, thinking the problem might be a Windows 8 thing. When I reinstalled EasyBCD in the new Windows, I found that I could get to Netrunner with the grub it installed in sda3, so it installed grub in both places!

I decided to install Netrunner again, so I downloaded a fresh copy, checked the hash, made another USB stick with Rufus (that’s the tool I use for all the installations), formatted the Linux partitions, and reinstalled. The results were exactly the same. Grub installed in both the Windows boot sector AND sda3.

Is this how it is supposed to work? If so, it’s the only distro I’ve run across that does that. I installed Netrunner 14 on the system last night, it installed without incident, and I’m happily evaluating it as we speak. I hope that this problem is something I did wrong, or that I missed about the system, because I would really like to use the rolling release. At the present time, I still need Windows on my primary machines, and don’t want to have to reinstall them. Sorry this is so long.


I’m assuming you have uefi set to bios mode, yes.
I’d like to add that grub2 is perfectly capable of booting many installed OS including all versions of windows.

I’m not sure how Rufus creates it’s live USB from an ISO since I have never used that before, but I do know that unetbootin and similar utilities are not recommended, the ISO has to written to the USB as a DVD Image and not on any other kind of partition or file format. Netrunner rolling is based on Manjaro Linux, here is the guide to burning their ISO:

Now, as far as Thus (GUI Installer) putting grub in both places, I can’t answer that one, you’ll need to ask that question on the Manjaro forums. https://forum.manjaro.org/index.php

Thank you for answering. Not a uefi machine, so not an issue. I know grub 2 will boot the Windows machine, so what? What happens when I replace the distro with another? The whole idea behind EasyBCD and partitioning is so one OS doesn’t interfere with the other in any way.

I read a thread on this forum that recommended Rufus for usb’s of Netrunner, I already checked that out, although it’s a non-issue as the live boot worked, and the installation, after a fashion. Rufus writes in DVD format, that’s why people use it.

I guess you’re right about asking the question on the Manjaro forum. I’ll do that if I get no further information here.

On edit: Reading this over, I didn’t mean to sound so snippy. I admittedly have an awful lot to learn about Arch and Manjaro. This is my first time looking at a distro based upon either one. All the prior candidates were Ubuntu or Debian-based.

Thanks again,


That’s not a problem, I too can get snippy at times. My point was that easyBCD might be what has tripped up the installer, but since I’ve never tried it I couldn’t tell you. that’s the only reason I suggested asking the Manjaro developers. Keep in mind also that Manjaro as well as Blue Systems, KaOS, Maui, Chakra, and other KDE/QT developers are currently working on and testing a new QT based distribution agnostic installer called CALAMARES: https://calamares.github.io/

Thank you, I will check-out the Manjaro forum. What I didn’t get is why the installer would even look at the MBR on sda1.


I’m not sure, it could still have something to do with how easyBCD does something that the Manjaro Installer isn’t programmed to handle, but since I have never used easyBCD, well you know.

I installed Manjaro, with both the new installer and the text-based version, and the same thing happened as happened with Netrunner. Apparently, this is not a contingency the Manjaro (or Arch) developers considered. No problem, that’s the way it works, and it has nothing to do with Netrunner.

I’m putting 14 on one of my primary systems, and rolling on the test system, at least until I’m more comfortable with the way Arch/Manjaro/Netrunner works. I like the distro too much to give up on it. You guys did a heck of a job!


I’m glad you hear that you decided to stick with Netrunner, i think you will find both editions enjoyable, If you ever have any issues be assured we are always here to help.

I’d like to let you know to keep an eye out here in the Netrunner Rolling sub-forum for my update-pack announcements. Occasionally the update-packs may be accompanied by some special instructions for them to succeed. I usually get these update-pack announcements posted within a few hours of them being released. Sometimes there are also security and bug fix releases in the interim between the update-packs, I post these here as well.

PS. If your interested in having an update notifier in your system tray then you’ll need to install octopi-notifier, but even then I would still check here in the forums for my announcements before running the updates.

sudo pacman -S octopi-notifier