[SOLVED] Intel Graphics Installer for Linux not supported

I have a laptop with Intel’s integrated graphics. I heard good opinions about Intel Graphics Installer for Linux:
e.g. http://www.omgubuntu.co.uk/2014/05/intel-linux-graphics-driver-installer-1-0-5
and the download on Intel’s page: https://01.org/linuxgraphics/downloads
I run it on my other Intel-based computer with Kubuntu and it works. But on Netrunner 14 Frontier, which is a (K)Ubuntu 14.04 derivative, it gives me “Distribution not supported” message and quits.

Why is that? Just a minor bug with Netrunner being capable but just not recognized? Or it has nuts and bolts deep there under the hood different than its forefather ? Or maybe there’s no need for this sort of improvement?


Yeah this is most probably the reason.
In my opinion especially if the Intel chip you have is not the latest generation it is not necessary to upgrade.

Yea, unfortunately the Intel installer looks at the output of lsb_release to determine what your distribution is, and what version of it you are running.

You’ll need to do this if you really need it to work:

$ sudo cp /etc/lsb-release /etc/lsb-release.bak
$ kdesudo kate /etc/lsb-release

Replace with:

and save file, then:

$ sudo intel-linux-graphics-installer

Follow installer and wait for it to ask you to reboot

$ sudo rm /etc/lsb-release
$ sudo mv /etc/lsb-release.bak /etc/lsb-release


Thanks for your answers you guys!

It’s Integrated Intel HD Graphics 4400 which comes with Lenovo Yoga 2 Pro, 4th Gen Intel Core i7

How safe is that? Are you sure I won’t mess up some other “installers”? E.g. package manager or PIP for Python?


That’s why (if you look closely) you would be backing up the original file first and then restoring after running the Intel Installer but before rebooting.

Technically it’s just a string and only used to identify your distribution. As the base system of Ubuntu and netrunner is the same and when removing the default value “This is Ubuntu” kicks in there shouldn’t be a problem.
As advised it makes sense to change this back after installation of the driver is completed.

Thanks! The trick shown by AJSlye worked with one slight amendment. The /etc/lsb-release file has to look like this:

In AJSlye original post there was still Netrunner in the last line and it’s not working then.


Nice that it works for you. The easiest trick btw. is to just remove the file. By removing the file it will default to this values above :slight_smile:

I wrote a little script, which runs Intel Graphics Installer and after it finishes reverts back to Netrunner’s original files.


sudo cp /etc/lsb-release /etc/lsb-release.bak
sudo echo -e "DISTRIB_ID=Ubuntu\nDISTRIB_RELEASE=14.04\nDISTRIB_CODENAME=trusty\nDISTRIB_DESCRIPTION=\"Ubuntu 14.04 LTS\"" > lsb.tmp
sudo mv lsb.tmp /etc/lsb-release
sudo intel-linux-graphics-installer
sudo rm /etc/lsb-release
sudo mv /etc/lsb-release.bak /etc/lsb-release

Nice. :slight_smile: