[Solved] Intel HD4000 & Triple monitor

Recently got a new laptop(Thinkpad L450, Intel Broadwell graphics & Dock) wanted to try netrunner. Everything looked great until I tried to connect my 2nd external monitor. .

if I connect it on boot I get the KDE login screen on all 3 screens and then 3 blank screens
if I boot with 1 or 2 then try to connect the 3rd it either doesn’t get detected or it goes to blank screens again.

I have tried non-proprietary driver and updating the proprietary driver, it works in Windows & (k)Ubuntu

Does anyone know how to fix this? :frowning:

Note: This thread is solved but I’m not 100% sure how.

Intel doesn’t have a proprietary GPU Linux driver, what driver are you trying to use?
First try disabling the compositor Ctrl+F12.
If that doesn’t work try using uxa or glamor instead of sna in you xorg.conf file.

If that still doesn’t help you could try using DRI3, this seems to be the current workaround for newer Intel graphics cards.

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
    Option      "DRI"    "3"

Maybe proprietary isn’t the right word. I’ve tried the additional drivers and I’ve downloaded the intel drivers from the intel website.

Additional Drivers: I’ve tried both options

Intel driver installer:

I’ve tried the options that you suggested (or at least I copied them into a new file /etc/X11/xorg.conf) but doesn’t seem to have helped.

Where did you add that xorg.conf file?
Xorg should be using the file under usr/share/X11/xorg.conf.d/intel.conf or something similar.

I had put it in /etc/X11/xorg.conf (it’s been awhile since I played around with xorg configs) and it’t seemed to be loaded based on xorg log

I moved it to /usr/share/share/X11/xorg.conf.d/intel.conf but hasn’t improved anything.

In that file does it list the monitors?

I’m not sure if this will be helpfull or not but here it is anyway:

So weirdly it started working… I haven’y touched the monitors config in xorg.

I rebooted into kubuntu live usb to have a look at the xorg config, rebooted to netrunner and suddenly it started working. I now have all 3 monitors working and (although a big unusable for a minute or two) it continued without any issues when being connected/disconnected from the dock.

Thanks-for your help, wish I knew what fixed it

I’d say probably the reboot after the changes were made.
Anyway, at least it’s working now. :wink: