[solved] is there a way to install Firefox 37.0.1

Hello dear friends!

I’ve tried to install Firefox 37.0.1, but found no way to make it work. Maybe you can help me get out of my doubts, if this is possible with Netrunner 15.

thank you so much!


If you need the KDE integration then follow this guide:

And then just wait for them to finish adding the Plasma patches to Firefox 37 and up.

Other wise just install the version in the security repository or by adding the *-updates repository:

which are already updated to version 37+.

What do you mean with “If you need KDE …”?

Anyhow, thank you very much!!! Will give it a try. Have to setup the system newly, too much trying for a nOOb :wink:

Will come back when done and tell you if it worked!


I didn’t say “If you need KDE”, I said “If you need the KDE integration” In other words, the patched version that is more compatible with Plasma/KDE than stock Firefox. Did you not follow the first link I gave you?

Oh yes, I did, but it would not go over ver. 36.0.1. I am most probably too inexperienced to do the update to 37.0.1. And when you speak about secure repository, I just can’t follow. I opened Synaptic Package Manager, Firefox Plasma is there, installed, ver. 36.0.1. I downloaded and extracted the 37.0.1+ package, but I don’t know how to go further. :s
Well, no luck here, it’s all so different …
Thanks for help!!!

Yes, I know it takes time to integrate the KDE/Plasma patches into new Firefox releases.

firefox-37.0.1 is available in synaptic ,you must force version .

type firefox in synaptic search bar the installed version will be at top, click it, click package>force version in the menu (top left) click the drop down in the force version window that will open and select the 37.0.1.version then click force.

just one note ,the good people hear at Netrunner have pined a priority of 1000 to the 36.0.1 version with the KDE/plasma integration which means that the next time you update you will be downgraded from 37.0.1 to 36.0.1 unless you "lock version on the 37.0.1 package ,the pining is why you dident see it in the first place .

AND IT WORKED! Thank you very much. Great!!! Have a beautiful day!