[solved] mencoder? photofilmstrip?

Is there a mencoder package for Netrunner 17/Wily?

I want to install photofilmstrip from the “Highly explosive” PPA https://launchpad.net/~dhor/+archive/ubuntu/myway - but photofilmstrip needs mencoder. In Debian it’s no problem, both packages are available in the standard Debian repositories…

No mencoder, no photofilmstrip. No photofilmstrip, sulky dad…

You might want to read this thread:
http://ubuntuforums.org/showthread.php?t=2302154

Thanks but that doesn’t help. The PPA mentioned in the thread (which solved the problem for the thread starter) is for mplayer only, without mencoder.

I have managed to install it from Xenial. It pulled a few other Xenial packages in so I hope it won’t break the system.

Very sorry I couldn’ t help. You may wish to widen your search for assistance by going over to the Kubuntu or Ubuntu forums, also askubuntu is great for getting technical assistance like this.
Good Hunting!

It looks like you may have jumped through a lot of unnecessary hoops.

The photofilmstrip project dropped it’s dependency on mencoder due to it no longer being maintained, and thus dropped from the mplayer source code.

If you’d like a cleaner system, then just revert anything you’ve done to your system so far and remove the PPA’s you’ve used in the process. Then download and install the latest version (deb file) from photofilmstrip’s sourceforge page.
https://sourceforge.net/projects/photostoryx

Update: It also looks lie Photofilmstrip is no longer maintained as of 2014.
You might want to start looking for an alternative application.

I’ve installed the current version, from dhor’s “Highly explosoive!” PPA (2.1.0-1dhor~wily). It’s the same version as the one from sourceforge project site - and it still needs mencoder. Where did you get the info that the project dropped the mencoder dependency?

I didn’t find any alternative that does the same as photofilmstrip in the same easy way or even more easier (choose music file, choose pictures, let create).

Actually, from the sourceforge deb package and the SVN trunk branches control file:
https://sourceforge.net/p/photostoryx/code/HEAD/tree/trunk/debian/control

And now from dhor’s “Highly explosoive!” PPA’s deb package control file:

Not the same.

While it can still use mencoder it doesn’t depend on it anymore, it now uses gstreamer as the default renderer.
There was also a libav (ffmpeg) renderer as well, but that was removed.

Browse the commits if your sceptical:
https://sourceforge.net/p/photostoryx/code/commit_browser
[r473] LibAv-Renderer (ffmpeg) removed

Thanks for the clarification! :slight_smile: