[SOLVED] Meta+Tab fails to switch activieties

Pressing Meta+Tab does nothing though it should switch activity. I did check that in System Settings -> Other -> Activities -> Switching the key shortcut is set.

Anything to do with this?

I’m running Netrunner 17 on Lenovo 2 Pro.
Intel® Core™ i7-4500U CPU @ 1.80GHz

OS: “Netrunner” “17”

System: Linux 4.2.0-19-generic x86_64
Plasma: 5.4.3
Display Info
Vendor: Mesa DRI Intel® Haswell Mobile
2D driver: intel
3D driver: Unknown classic (11.0.2)

I really liked that feature - please fix it…

This should be fixed already.
Do you have at least two activities active? It only switches between active ones and does not start inactive as far as I know.

Yes, I have them both active. Each Has 3 desktops. Meta+Q works fine (it displays a bar with activities to choose from), but Meta+Tab is more fun. The fix
$ kquitapp plasmashell
$ /usr/bin/plasmashell --shut-up &> /dev/null &
suggested in the KDE Bugs forum does NOT work either.

Just in case can you try to change to Folder View Layout under Netrunner Desktop Settings (in the right click contextmenu) to see if it makes any difference.

Redefining the key shortcut (e.g. Ctrl+Tab) does nothing.

Nope… I’ve tested Netrunner Desktop and the regular Desktop. Nope - no change.

Seems to be still that bug then.
Can you comment on the original bug about it and state your Plasma version running so that someone from the KDE devs can take a look.

OK. I’ve posted the bug https://bugs.kde.org/show_bug.cgi?id=342186

Unfortunately, the upgrade to Plasma 5.5.1 did not fix the issue with no activities being switch with Meta+Tab key. Quirks in Activities remained as they were.

Are you sure that the other activity isn’t stopped when trying to switch ?
I cannot reproduce it here with Plasma 5.5 . When I have my other activity started I can switch with no problem between the two (with Meta/Superkey + Tab).

Did you try already recreating (or creating a new) Activity under Plasma 5.5 ? Maybe its an issue with this particular activity created on an older Plasma version.

OK. Let’s do it brutal but the easiest way… How can I restore Netrunner’s default settings on my user account (overwriting my settings)? I’m not that much attached to my personal looks & feels.

Before removing anything you could test with a new user and see if it works there.

Copy them from /usr/share/netrunner-default-settings (there are settings for kde4 sc related software and plasma 5)
KDE SC 4.x related stuff goes into ~/.kde and plasma 5 related stuff to ~/.config

I can confirm, I also can’t switch between activities with Meta-Tab. Both (default) activities are active, I can switch between them in activities list (Meta-Q). Creating new activities doesn’t help.

I’m totally sure that all activities ARE active. Meta+Q does work.

I’ve set a new user - same problems. I’ve reset my own desktop - same problems.

Is it a keyboard issue? My Lenovo Yoga 2 Pro uses AccuType keyboard. Or is it the graphics driver? Integrated Intel HD Graphics 4400 - I’ve tried using processor microcode firmware for intel CPUs from intel-microcode and not using it. Same problem :-/

Or do I miss some plasma-something-something package?


I did the usual

sudo apt-get update sudo apt-get dist-upgrade

and BAM! There were some plasma related packages that seemed to fix the issue.

Glad the issue is solved with our latest update :slight_smile: