[SOLVED] mp3 files open in Qmmp regardless

Since the chaos of the upgrade to 14.1 (I still seem to be on 14.04) mp3 files open in Qmmp regardless of the settings in File Associations. I have promoted Clementine to the top of all relevant lists for audio files and put Qmmp or Enqueue in Qmmp at the bottom, to no effect. Using the right-click Dolphin menu I have set Clementine to open mp3, and the system settings claim to have updated, but mp3s still open in Qmmp. Ogg files open correctly in Clementine.

Well Netrunner 14.x is going to continue to be based on 14.04 as it is an LTS release:

Are you sure you changed all of the entries for mp3, etc. under System Settings > File Associations?
I can’t test this because I removed Qnmmp, I don’t personally never liked winamp or any of it’s clones.

I have been through File Assocs several times looking for references to mp3. The problem is that they are listed by name, not file extension, so you only know what the entry really refers to once it is open. Maybe if I remove Qmmp, which I too have no use for, this will solve my problems.
I would have expected, though, that specifying Clementine through the Dolphin right-click menu would work, it has done for other file types in the past.

Type mp3 in the search bar, there should be 4 results:

I removed Qmmp, but now VLC comes up whatever.
In addition to the 4 that you have I had “MP3” which specified Clementine and Audacity. I removed that and then found that “mpeg” had VLC at the top. I moved it down, applied, the update message appeared, and disppeared without any progress bar appearing. VLC remains at the top. It looks like changes via the File Assocs dialogue are not being applied. Running System Settings as Root does not work much better, Clementine stays at the top temporarily but VLC is back next time I look. Is this a permissions problem?

Don’t run as root as this would only update the mime database of the root user.
What about right clicking the file and going into properties and then setting the file association from there. Does this work for you?
If not make sure the file ~/.local/share/applications/mimeapps.list is writable by your user.
Of course you could also try to directly edit this file with a texteditor if you want.
If you do run update-desktop-database afterwards.

I had tried the right click any number of times with no effect.
~/.local/share/applications/mimeapps.list is editable and I have modified it accordingly. mp3 files now open in Clementine, and the File Assocs dialogue reflects my changes, though it still includes multipe mentions of qmmp, but down the bottom.

Thanks. I now know where to look.

same problem. vlc takes over. can not set file associations. the original problem is when vlc plays audio there is a constant hiccup - little pauses. want to set clementine for audio and vlc for video.

Does the above not work ?

I fixed mine by editing ~/.local/share/applications/mimeapps.list. See attached. (I had to change the name to attach it.) The file associations dialogue did not work properly, this bypasses it.