[Solved) No Admin Rights in Dolphin and Krusader

There are no Admin Rights in Dolphin and also in Krusader. I have set the respective services. To work with Admin Rights, I have installed Thunar.

Thats the only bug I see in this Distribution. All others works fine and very fast. I think, thats one of the best KDE Distris I have worke with. Thanks for the good Job.

It’s not a bug. This is intentional by kde developers to remove root privilege for its GUI apps to prevent exploits

See below for full details :


I’m not quite sure what you meant by set the respective services, sudo is already set up by default.

Dolphin, kate, etc. are part of the KDE applications suite and use plasma frameworks new mechanism for elevating user privileges (interacting with sudo). You can no longer use sudo or kdesu from the command line, or with kde-servicemenus-rootactions from within dolphin for starting these KDE applications. However, you can open any file in the file system, and depending on the files permissions, you will be asked for your administrative password upon saving the file back to the hard drive.

Thanks for this Information. It was a new knowledge fot me. I have test few KDE Distributions without this “Problem”. But now I know, thats not a Problem and so I edit this files with the terminal.

This is how all KDE apps are going to behave, there is no reason to edit via the command line.
You just open up the files, edit them, and click save like you would any other file, the only difference is if they are system or root files, you will be asked for your password when you go to save the files.

I tested Dolphin and Krusader again. Thats all right what you wrote in your answer. Perhaps I was a little bit drunken as I wrote the post before. Sorry…
By the way…I am delighted by the fast answers of the members in that Forum.

Thanks, I’m glad we could help.
If you don’t mind, could you add [SOLVED] to the beginning of your thread title? This would be greatly appreciated as this helps others find answers to their questions faster, and helps to reduce the number of repeat questions.

How can I edit my Thread Title? No answer found in “Help”

Click on edit on your original post and use the full edit feature.
This will expose the post subject line to be edited.
Full edit is the same advanced editor that you had when you originally posting this thread.