[SOLVED] No Plymouth boot splash

I’m not seeing the Plymouth boot splash and, after trawling through /var/log/pacman.log, I’m seeing this:

[quote]26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] ==================================================================================
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 1. To make Plymouth work:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 1.1. Add “plymouth” to HOOKS after “base” and “udev” in /etc/mkinitcpio.conf
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 1.2. Add ‘quiet splash’ to the grub command line in /etc/default/grub
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 1.3. Rebuild your initrd image (# mkinitcpio -p [kernel preset name]).
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] E.g.: sudo mkinitcpio -p linux38
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 2. To enable encryption, replace “encrypt” with “plymouth-encrypt” in
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] mkinitcpio.conf and rebuild your initrd image.
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 3. You will also need to rebuild your initrd image every time you change your theme
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] (the default is set as ‘spinfinity’).
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] To list all plymouth themes:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] plymouth-set-default-theme -l
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] To change theme:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] # plymouth-set-default-theme
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] To rebuild initrd image:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] # mkinitcpio -p
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 4. For Smooth Transition to Display Manager you have to:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 4.1. See the Wiki Page (link in 5) to prepare your Display Manager
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 4.2. Disable your Display Manager Unit
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] E.g. : systemctl disable kdm.service
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 4.3. Enable the respective DM-plymouth Unit (GDM,KDM,Lightdm,LXDM units provided)
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] E.g. : systemctl enable kdm-plymouth.service
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] 5. For more information please visit the Wiki page:
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] https://wiki.archlinux.org/index.php/Plymouth
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET]
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] OBS. If you have any leftover “kill Plymouth” lines in /etc/rc.local or ~/.xinitrc
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] they are no longer required.
26/08/2014 13:00:35 [2014-08-26 09:44] [ALPM-SCRIPTLET] ==================================================================================
[/quote]

Do I actually need to do all that stuff or is there an easier way to get it working?

Yes and No, plymouth was installed and the theme was set up but the installer didn’t set it up to load on boot.
You’ll need to edit /etc/default/grub and and add splash to the end of this line like this:

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=d094cfaf-be3c-494c-8817-8c36ddea4ac5 quiet splash"

Then edit /etc/mkinitcpio.conf and add plymouth right after after base and udev like this:

HOOKS="base udev plymouth autodetect modconf block keyboard keymap resume filesystems fsck"

then run:

sudo mkinitcpio -p linux
sudo update-grub

Note:
If your running the opensource drivers and want early KMS start add one of these to the MODULES line in /etc/mkinitcpio.conf:

MODULES="i915"
MODULES="radeon"
MODULES="nouveau"

OK, I’ve got as far as here but here’s the output from the above command:

[martin@sgc ~]$ sudo mkinitcpio -p linux [sudo] password for martin: ==> ERROR: Preset not found: `/etc/mkinitcpio.d/linux.preset' [martin@sgc ~]$
If I look in /etc/mkinitcpio.d I can see linux310.preset so I’m assuming that the correct command should be sudo mkinitcpio -p linux310. As I don’t want to trash my new setup, I’ll await your comments before proceeding, thanks.

[quote]
If I look in /etc/mkinitcpio.d I can see linux310.preset so I’m assuming that the correct command should be sudo mkinitcpio -p linux310. As I don’t want to trash my new setup, I’ll await your comments before proceeding, thanks.[/quote]

Yes exactly this is the right command.

OK, I’ve followed all the steps, rebooted and I now have the plymouth boot splash. Thanks for your help.

Looks like I may have marked this topic as solved a bit too soon:

Switched on the PC this morning and got the grub boot menu, followed by the plymouth boot splash, followed by a tty login screen which very quickly changed to a completely blank black screen and that was the end of that. The only way out was to switch off the PC and wait a few minutes before switching back on. This time though, I got the graphical login screen instead of the tty login screen/blank screen and I was able to log in OK. I’ll have to see what happens when I switch on tomorrow morning :-/

This has nothing todo with plymouth however and seems to be another issue.

Yes, it’s a display adapter / driver issue. if you switch consoles the log-in in screen should appear (example: ctrl+alt+f1 then ctrl+alt+f7). I’m not sure what causes this exactly, it is an intermittent issue and happens with all display managers and graphics cards.

OK, thanks for that and just to keep you updated, the system booted just fine this morning but the transition between plymouth and the graphical login screen was not seamless. A tty login screen briefly appeared followed by a blank screen with a flashing cursor in the top-left-hand corner and, after a few seconds, the graphical login screen appeared. I was then able to login and I then got the KSplash screen which transitioned smoothly to the KDE desktop. Anyway, my original question has been answered and thank you both very much for your help.
[hr]
Just had a thought …

Up until very recently I’d always used the nVidia proprietary drivers but I’m now using the nouveau drivers, as they seem to have improved greatly since I last tried them. Perhaps I should try using the nVidia drivers again just to see what happens?

Selfishly, I’d be very interested to see your results. :slight_smile:

I’m running the proprietary drivers, and I’d noticed that I had no plymouth bootsplash. BUT, under Ubuntu (and derivatives) I have a script that always fixes that for me, and I hadn’t dug into things enough to have any idea whether it could be the same problem for me here as crops up on Ubuntu derivaties - I checked my pacman.log after reading your post, and sure enough I actually have the same issue you started with.

I really hadn’t planned to mess with Plymouth because of my proprietary drivers, and because I don’t understand how Plymouth functions well enough to troubleshoot it at all. (Despite about a year on arch in the not too distant past - I never bothered with Plymouth there, either.)

So if you do it, please post here regarding how it goes, and I may ride your coattails :slight_smile:

If you followed the prior instructions for KMS I don’t know if that will be something you have to undo when you switch to proprietary or not…

The blank tty screen is SDDM waiting for Plymouth to stop before it tries to load, this is normal when using Plymouth.

Yes if you switch to the proprietary drivers you will need to remove the modules line from /etc/mkinitcpio.conf and run sudo mkinitcpio -p linux*** again.

I spent quite some time on this yesterday and, after almost trashing my system, I came to the conclusion that it wasn’t worth the hassle, as there was no noticable difference :frowning:

I managed to install the nvidia drivers without any problems but I got in a bit of a mess configuring everything because I hadn’t realised that things are done differently to what I’ve been accustomed to. I only found out after reading the Manjaro wiki after I got in a mess (should have read it first!)

As you already have the proprietary drivers installed and working, you may have more success than I did.

Yes, Manjaro has it’s own tools for managing the systems hardware and software, these tools should be listed and/or demonstrated on the tutorial read me page. There should be a link to the Manjaro Wiki on this page as well as to the forums and blog pages.

OK and thanks for that.

I decided to do a fresh clean install of “Rolling” this morning with a view to trying all this again because I discovered that I’d overlooked two very important steps:

sudo systemctl disable sddm.service

and …

sudo systemctl enable kdm-plymouth.service

I now have it all working smoothly with the “nouveau” drivers :smiley:
When I have a bit more time(tomorrow), I’ll post a detailed account of exactly what I did :wink:

That’s fine for now but KDM is going to be retired and succeeded by SDDM upstream in the near future.

PS. By upstream I meant the KDE community and not Manjaro, just felt that needed clarification.

Thanks for the clarification.

Here’s a step by step account of how I got plymouth working to my satisfaction with the nouveau drivers:

[1] Added splash to the end of the following line in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=0730e409-5922-4b51-841c-79b3e2102aa6 quiet"

It now looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=0730e409-5922-4b51-841c-79b3e2102aa6 quiet splash"

[2] Added plymouth to the hooks array in /etc/mkinitcpio.conf after base and udev

[3] Changed MODULES="" to MODULES =“nouveau” in /etc/mkinitcpio.conf

[4]

sudo mkinitcpio -p linux310

[5]

sudo update-grub

[6]

sudo systemctl disable sddm.service

[7]

sudo systemctl enable kdm-plymouth.service

[8] Reboot

I don’t see any reason why this shouldn’t work with the proprietary nvidia drivers providing step3 is skipped but I haven’t tried it. If anyone does try it, I would be interested to hear the outcome.

Yes, Plymouth works just fine with the proprietary drivers, only the Nvidia driver does not support KMS so the size will be larger, other than that it’s fine. The plymouth package doesn’t have a sddm-plymouth.service in it yet but I have created one myself, if you wish to try it extract it to /usr/lib/systemd/system and run: sudo systemctl enable sddm-plymouth.service

OK and thanks for that. I’ve just grabbed a copy and tucked it away for the next time I have a play about with plymouth.

BTW … I don’t see any additional installable themes for SDDM anywhere.

Yea, there are only a few available online besides the ones that comes with it, here is what ones I’ve found so far.

The Manjaro repository has this:
sddm-manjaro-theme

The AUR contains these:
sddm-archlinux-theme-git
sddm-futuristic-theme

and here is the breeze theme:
https://code.launchpad.net/~neon/project-neon5/sddm-theme-breeze

The version of sddm in the blueshell repository is older than the version available from the Manjaro community repository. However, they are both out of date compared to whats available in git and from the AUR:
Git Hub: https://github.com/sddm/sddm/blob/master/ChangeLog
AUR: https://aur.archlinux.org/packages/?O=0&C=0&SeB=nd&K=sddm&outdated=&SB=n&SO=a&PP=50&do_Search=Go