Netrunner Home

[SOLVED] Open port 443 for banking software?


#1

Hi,

for my banking software i need the port 443 open. The test with the banking software tells me that the port is not available.

In netrunner 17.10, my former os, the software is working perfect.

How can i open this port? For your information: in terminal i get the message
iptables: unrecognized service

Thanks in advance!

Dieter


#2

It should open the port automatically. 443 is TLS (https) port. Have you checked if your router is maybe blocking something? Also maybe ask the support forum for the application.


#3

thanks for your answer. I asked in this forum, because the same software is, in the “same” network with exact the same router, working perfect in netrunner 17.10. That’s what is irritating me …
Any ideas?
Ciao!
Dieter


#4

Can you tell us which banking software it is.
Have you checked any documentation on that software.

Does it need inbound or outbound port opening? Inbound would be very very weird and needs opening the port on your router for your machine.
Did you manually had to change anything on Netrunner 17.10?
If not then it might be a bug in the application actually that it does not support the current Netrunner/Debian base.


#5

Thanks again
I’m using moneyplex 16 (64bit) for linux. In the database of moneyplex I found the following hint:`

Es kann sein, dass die SSL-Pakete auf dem System nicht kompatibel mit den in moneyplex genutzten Paketen sind. Dies zeigt sich in moneyplex, wenn man auf Einstellungen, Internetverbindung geht und dann die Funktion „Internetverbindung prüfen“ ausführt. 

Es wird dann beim Testen von  *Port*   *443*  ein Fehler angezeigt. Wenn ein Fehler bei allen  *Port* s angezeigt werden sollte, hat es eine andere Ursache (Firewall, resolve.conf, etc.)

libopenssl1_1 ist nicht kompatibel zu den in moneyplex genutzten Bibliotheken.

Lösungsmöglichkeit:
Beenden Sie moneyplex. Öffnen Sie die Datei settings.ini, die sich im Ordner moneyplex befindet, in einem Text-Editor. Fügen Sie die folgenden Option am Anfang der Datei hinzu:

[OpenSSL] 
libssl=./openssl/libssl.so.1.0.0 
libcrypto=./openssl/libcrypto.so.1.0.0

Ok, I tried it with

[OpenSSL] 
libssl=./openssl/libssl.so.1.1
libcrypto=./openssl/libcrypto.so.1.1

No success! I guess, the paths are not correct. Or anything else is wrong?
Any ideas?

Ciao!

Dieter


#6

Not sure if this will work as moneyplex states it does not support libssl 1.1.
But the paths to the libs is /usr/lib/x86_64-linux-gnu/libssl.so.1.1 and /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1

edit: Reading this again I think what might be meant aswell is really use the openssl version moneyplex ships by default in their openssl folder. So using the exact configuration suggested in the error message might be the correct way to fixing the issue.


#7

Thanks for your help. Meanwhile I contacted the support of moneyplex (in my opinion the best banking software for linux)
The folder “openssl” didn’t exist in moneyplex. No idea why, but now I got the necessary files and everything is working.
Ciao!

Dieter