[Solved] Problem with yaourt.


Today i want install some app from aur repository (opera-beta, spotify, ffmpeg-opera-beta). But in terminal i see this:
==> Downloading opera-beta PKGBUILD from AUR…
(23) Failed writing body
==> ERROR: opera-beta not found in AUR.

Press any key to continue…

Is the same for spotify and ffmpeg. I wonder what’s wrong?

That’s a curl error. It means that curl could not write to a file.
That output looks like it was from within octopi.
Do you get the same error using yaourt from the command line?

Also, have you updated octopi, yaourt, curl or openssl from any other source than the main repositories?

Note: ffmpeg is already provided on the system, do not update this from the AUR.

I’ll look at the other two.

I think I’ve found the issue, did you try installing spotify first?
If so, it depends on libcurl-compat from the AUR which is NOT compatible with yaourt, libcurl-compat also conflicts with the official libcurl-gnutls package that is needed by steam-manjaro.

I’d recommended that you remove libcurl-compat and reinstall libcurl-gnutls if you previously removed it.
The spotify-stable AUR entry would be the best way to get spotify installed as it does not have this dependency

Here is the wiki page for installing spotify on Manjaro:

Just curious, Opera 36 is already available in the repositories, is there a reason that you need the beta version?

When i try install opera-beta in the terminal i have this:
[kamil@kamil-pc ~]$ yaourt opera-beta
1 aur/opera-beta 36.0.2130.29-1 (27) (1.35)
A fast and secure web browser and Internet suite - beta stream
2 aur/opera-beta-ffmpeg-codecs 49.0.2623.23-1 (2) (0.34)
additional support for proprietary codecs for opera-beta
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==> 1

==> Downloading opera-beta PKGBUILD from AUR…
x .SRCINFO: Write failed
x PKGBUILD: Write failed
x default: Write failed
x opera: Write failed
x opera.install: Write failed
bsdtar: Error exit delayed from previous errors.

More likely to come out tomorrow. Sorry i should have explained how much of a heads up I was giving!

There is a missing “)” at the end of line of the second alternative download source.

Please install opera-ffmpeg-codecs for h264 support.

Please update to Opera Beta 35 http://www.opera.com/blogs/desktop/2015/12/opera-35-beta-release/

Opera beta 36 http://www.opera.com/blogs/desktop/2016/02/initial-opera-beta-36-release/

opera-beta 36.0.2130.29-1 (2016-03-17 21:47)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] (“A” to abort)
==> ------------------------------------
I dont update octopi and yaourt. Couple days ago i can install apps from the aur repository.Today i cant. 3 day ago i have installed opera-beta and it work fine. Today i uninstall it. But i want install again, and i can’t. I dont install spotify because i have the same problem what opera.

Ok, in that case try clearing out your /tmp directory.

I just installed Opera Beta here without the issue.
However, opera 36.0.2130.32-2 is already in the repositories, and yaourt is installing 36.0.2130.29 from the AUR, which is actually older.

==> Continue building opera-beta ? [Y/n] ==> ------------------------------------ ==> ==> Building and installing package ==> Making package: opera-beta 36.0.2130.29-1 (Thu Mar 24 14:00:56 EDT 2016) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found opera -> Found default -> Downloading opera-beta_36.0.2130.29_amd64.deb...
The only thing i see in that list besides spotify-stable that you would possibly need from the AUR would be opera-ffmpeg-codecs.

How can i clear tmp directory?

And how can i update aur repo?

With this command:

sudo rm -r /tmp/*

I clear my tmp folder and it work. Many thanks.

The AUR is not indexed like the standard repositories, it changes too often.
Each time you use yaourt, or octopi’s AUR search function, the AUR is manually searched.

By default, the /tmp directory is not a physical directory on the hard drive, it’s actually a /tmpfs partition that is created upon boot.
This is of corse unless you created a physical partition and mounted /tmp to it yourself.
Your either installing too much stuff between reboots, or you’ll need to increase the /tmp directory size.
You can adjust the /tmp directory size in your fstab.