[SOLVED] random graphics issues with nvidia

Problem: Randomly and in many different programs, I get fuzzy borders around my windows and in addition sometimes I get blocked text in the windows - but not in the program itself (for example Firefox menu has black box text but the web page is fine).[attachment=348][attachment=347] I’m been searching with various search terms, and trying various setting tweaks things but no luck so far. Fuzzy borders usually fix themselves with a minimize/maximize, but the black box font issue, I had to reboot. Especially hard to troubleshoot since it is random and search terms are not clearly defined.

When first running netrunner, I had to choose the non-free drivers to avoid the blank screen, so I 'm running nvidia driver:

inxi -G Graphics: Card: NVIDIA C61 [GeForce 6100 nForce 405] Display Server: X.Org 1.15.1 driver: nvidia Resolution: 1440x900@59.89hz GLX Renderer: GeForce 6100 nForce 405/integrated/SSE2 GLX Version: 2.1.2 NVIDIA 304.121

I haven’t seen this problem while running nvidia on Mint KDE on this machine
Any other ideas as I continue to test?
Thanks!

Do you have hybrid graphics on your machine Intel/Nvidia?

Not that I’m aware of.
My integrated GeForce 6100 doesn’t list that feature here:
http://www.nvidia.com/object/mobo_gpu_features_benefits.html#gf6nf4

NVIDIA GeForce 6-Series GPUs / NVIDIA nForce4 MCPs
If you check the 331 read me for supported chips, the Geforce 6100 is longer supported by the latest non-free driver, you will need to run the 304.xx nvidia-legacy driver or nouveau for that chip.

ftp://download.nvidia.com/XFree86/Linux-x86_64/331.20/README/supportedchips.html

Use Manjaro Settings Manager > Hardware Detection to change to a different driver.

Thanks, but I’m already using the 304.121 driver. Should I try to downgrade even further? I checked my Mint KDE and it is running 304.88 - maybe I’ll try that.

When first running netrunner (live), I had to choose the non-free drivers to avoid the blank screen …is switching to nouveau post-installation going to cause the same issue?

Thanks again.

You can’t use the 304.88 drivers they are not available anymore, also Netrunner Rolling (Manjaro) isn’t compatible with the Arch way of installing Nvidia drivers anymore. Next thing to check is the ISO you used to install your system with (md5sum), you might have a corrupt install/ISO, and never use UNetbootin with Netrunner Rolling (Manjaro) ISO’s, it won’t boot, work or install properly.

PS. Please try the free nouveau drivers if all else fails.

PSS. I almost forgot did you update the default libGL library after the last update?

MESA (all free drivers)
sudo mhwd-gpu --setgl mesa

NVIDIA (non-free)
sudo mhwd-gpu --setgl nvidia

CATALYST (non-free)
sudo mhwd-gpu --setgl catalyst

Also make sure your not using software composting or hardware openGL higher than your card can handle: System Settings > Workspace Behaviour > Desktop effects.[attachment=349]

[quote=“AJSlye, post:6, topic:2421”]
PSS. I almost forgot did you update the default libGL library after the last update?[/quote]

I did not. Are results below normal?

$ sudo mhwd-gpu --setgl nvidia
[sudo] password for user: 
libGl: '/usr/lib/nvidia/libGL.so'
libGLESv1: '/usr/lib/nvidia/libGLESv1_CM.so'
libGLESv2: '/usr/lib/nvidia/libGLESv2.so'
libEGL: '/usr/lib/nvidia/libEGL.so'
lib32-libGl: '/usr/lib32/nvidia/libGL.so'
lib32-libGLESv1: '/usr/lib32/nvidia/libGLESv1_CM.so'
lib32-libGLESv2: '/usr/lib32/nvidia/libGLESv2.so'
lib32-libEGL: '/usr/lib32/nvidia/libEGL.so'
libglx: '/usr/lib/nvidia/xorg/modules/extensions/libglx.so'

My compositing is set for OpenGL 2.0 which is supported per nvidia website for this card.
I turned off “Enable Desktop effects at startup”

Now I wait to see…
Thanks!
Bill

I have not had this graphics display problem since I did the stuff in post #7 above.

…so marking this solved!

Thanks!

Sorry I didn’t get bask to you sooner, I just realized that view new posts links is time sensitive and never saw your post.

Now to answer your question, Yes, that is normal.