[Solved] Schwarzer Bildschirm nach dem Booten

Hallo zusammen,

Gestern bin ich grandios an einer Installation von Netrunner 14 (und Rolling) 32-bit gescheitert. Die Hardware, welche mir Probleme macht, ist ein alter Sony Vaio VGN-FE11H Laptop. Hier ein paar Eckdaten:

CPU: Intel Core Duo T2300 1,66 Ghz
Speicher: 1GB/Go (2x512 MB)
Bildschirm: 15,4 WXGA X-black LCD
GraKa: Nvidia Geforce Go 7400

Die LiveCD bootet das System, der User wird automatisch angemeldet und dann kommt nur noch ein schwarzer Bildschirm wobei ich die Maus sehe und diese auch bewegen kann. Meine Vermutung geht dahin, dass die GraKa mit einer falschen Auflösung angesteuert wird. Habt Ihr eine Idee, wie ich dieses Problem beheben kann?

Schöne Grüße,
Marc

Hi Marc,

seit 5 Minuten gibt es eine neue Version von Rolling 32bit.
Falls Dich Plasma5 nicht davon abhält, könntest Du es mal mit der versuchen :slight_smile:

Hey starbuck,

danke für die Info. Leider zieht sich das Problem auch durch andere Distros. Habe jetzt schon LinuxMint 17.2 und Netrunner 16 ausprobiert, immer das Gleiche! Ich vermute, mit der GraKa Erkennung gibt es hier ein generelles Problem. Am weitesten komme ich noch mit NR 16 aber leider bekomme ich das Desktop dort nur im Softwaremode!

Ja das ist in der Tat so. Ein Bug, der leider immer noch im nouveau Treiber steckt. Es meldet einfach die falsche Kompatibilität von OpenGL für deine Karte. Die meisten dieser Chips können diese OpenGL Version aber nicht fehlerfrei.
Leider sorgt das bei den neuen modernen Desktops mit Compositing und Effekten dafür, dass dein Bildschirm schwarz bleibt.
Per Umschalt+Alt+F12 kannst du temporär (wenn du den schwarzen Bildschirm hast, nachdem Plasma gestartet ist) die Desktopeffekte abschalten.
Danach solltest du im reinen Softwaremodus die Möglichkeit haben die Effekte auch dauerhaft abzuschalten.
Bei Netrunner 14 kannst du die Effekte mit Forcierung auf OpenGL1 auch wieder aktivieren. Bei Netrunner 16 oder Rolling mit Plasma 5 ist dies leider nicht mehr möglich, da du da mindestens OpenGL 2 für brauchst.
Ich empfehle also entweder Xrender, falls du unbedingt Effekte brauchst, oder einfach Effekte abschalten.
Bei Plasma 5 kannst du, wie ich im anderen Thread auch schon erwähnt hatte, mal EGL (OpenGL ES) ausprobieren und schauen ob dort die Implementierung im Treiber für deine Karte besser funktioniert. (Da OpenGL ES ein abgespecktes OpenGL ist, sollte das evtl. sogar klappen)

Hoffe das hilft dir weiter.
Bei einigen neuen modernen Desktops Gnome 3 Shell oder Unity kann man die Desktopeffekte leider nicht abschalten, da kenne ich also jetzt keine Lösung die dir helfen könnte.

Erst Mal Danke für die umfangreiche Antwort. Ich würde also nun Netrunner 14 installieren, dann normal hochfahren, dann Umschalt+Alt+F12 drücken um in das Softwarerendering zu kommen und wie bekomme ich jetzt die OpenGL 1 Forcierung hin?

Du kannst in den Systemeinstellungen unter Arbeitsflächen-Effekte -> Reiter Erweitert -> Composite-Typ -> OpenGL 1.2 einstellen. (Wenn du es nicht auf Anhieb findest nutze bitte die Suche oben rechts)
Dann testen ob es klappt.

Bin gerade dabei, zu installieren. Ich habe gleich im “recovery mode” hochgefahren. Das Desktop wird dort in korrekter Auflösung im vollen 2D Support angezeigt. Lustig ist auch, dass der Sony nur DVD-R nimmt, bei DVD+R verweigert er das Hochfahren mit NR 14.

Installiert ist, hochgefahren im normalen Modus, schwarzer Bildschirm mit Maus erscheint, Umschalt+Alt+F12 gedrückt, es erscheint “GPU lookup - switching to software fbcon” und nichts passiert, nach einer gewissen Zeit kommt dann nur noch ein schwarzer Bildschirm.

Danach habe ich einen Neustart gemacht, die Shift Taste gehalten -> Erweiterte Bootoptionen -> Recovery Mode -> Im Recovery auf resume with normal boot -> Desktop erscheint. Das Desktop ist im Softwaremodus -> Einstellung auf OpenGL 1.2 -> Neustart

HEUREKA -> Das Desktop kommt in normalen Bootmodus.

Scheen Dank! :smiley:

Ein kleines Problem gibt es noch bei 14.2. Wo ist die Spracheinstellung hin? In den Systemeinstellungen gibt es keine Option dafür. Ich habe über Synaptic das deutsche Sprachpaket für KDE nachinstalliert. Aber Firefox weigert sich z.b. hartnäckig sein deutsches Sprachpaket zu nehmen (obwohl ich das englische schon entfernt habe!). Wie kann ich diese Option in der Systemeinstellung nachinstallieren?

oO das sieht nach einem weiteren Nouveau Bug aus, der völlig anderer Natur ist.
Das schlimme daran, der kann jederzeit wieder auftauchen.

Eine Lösung wäre es den Kernel zu patchen, aber ich denke das wirst du nicht machen wollen. Da dieser Patch nie in den offiziellen Kernel übernommen wurde schätze ich ist es eher ein Workaround und man hat den Grund für diesen Bug noch nicht gefunden.

Die Spracheinstellungen sollten unter den Regionalen Einstellungen zu finden sein.
Evtl. hilft hier auch wieder die Suche.
Die Spracheinstellung sollte spätestens beim nächsten Neustart komplett systemweit übernommen werden.

Eine Frage aus reinem Interesse. Hattest du bei der Installation nicht Deutsch als Sprache ausgewählt ?

Also einen Kernelpatch würde ich nicht unbedingt nachspielen wollen. Bin froh, dass es jetzt alles so gut läuft. Es sollte lieber etwas mehr Bugtracking seitens der Entwickler betrieben werden. Aber ich denke, mit der Meinung renne ich hier offene Türen ein :slight_smile:

Also die Regionalen Einstellungen tauchen in der Systemsteuerung nicht auf. Eigentlich sollten sie ja dort zu finden sein?! Bei der Installation hatte ich Deutsch angeklickt und es wurde auch während der Installation alles in Deutsch angezeigt. Nur beim nächsten Hochfahren war alles in Englisch und die Regionalen Einstellungen fehlen komplett! Inzwischen habe ich alle nötigen Pakete für Deutsch mit Hand nachinstalliert.

Normal ist das aber nicht oder?

Nein normal ist das nicht

Noch eine Idee, wie ich diese Einstellungen wieder installiert/angezeigt bekomme? Soweit ist nun alles in Deutsch, nur im Kicker sind die Knöpfe für Herunterfahren etc. noch alle in Englisch, bekomme ich aber nicht wirklich weg.

Leider hat sich noch ein Problem aufgetan. Das WLAN trennt sich ab und zu und wählt sich dann von selbst wieder ein. Kommt mir so vor, als würde das Modul abstürzen und dann wieder neu starten. lspci gibt mir: “06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)”

Ist da was bekannt, ob der Treiber dafür instabil ist?

Edit: Habe mich gerade etwas schlau gemacht. Selbst die Windows User haben Probleme mit diesen Netzwerkadapter. Das BIOS Update hatte darauf auch keine Wirkung. Also einen Edimax Nano rein und die Kiste läuft :slight_smile: