[Solved]: Setting up Epson WF-3640 printer

I am trying to set up an Epson WF-3640 printer. It is discovered but I am unable to install it as my default because I think the driver is not available. What would be the recommended way to go about setting it up? Thanks.


Printer driver:

yaourt -S epson-inkjet-printer-escpr


EPSON Image Scan! front-end for scanners and all-in-ones: iscan
EPSON Image Scan! data files: iscan-data

sudo pacman -S iscan iscan-data


Thanks for the detailed steps. I have carried them out successfully.

I now get the message:

Unable to locate printer "EPSON4DDC67.local"

Is there anything else I need to to do to get it going? Or have I left something out?


Yes, if it is a network printer do not use the dns-sd detected printer, Avahi under Manjaro doesn’t work properly for some reason.
You’ll need to input the IP address manually and use the search function.

For scaning over the network you’ll need the iscan-plugin-network:

yaourt -S iscan-plugin-network

Thank you, AJSlye.

That worked! The printer seems to be fortuitously allocated the same local IP address on the LAN, and once I entered it, I could start using the printer.

I have just discovered from this blog that to get it working via dns-sd one needs to do the following:

  1. Ensure that nss-mdns is installed:
pacman -Ss nss-mdns
  1. Edit /etc/nsswitch.conf and ensure that the line with hosts: reads thus:
hosts: files mdns_minimal dns mdns

Setting up the printer after that should be hassle-free and successful.