back to Netrunner | back to Blue Systems

[SOLVED] Slow boot time, Netrunner 17.03

Hi all,

I installed Netrunner 17.03 around a week ago and so far I am happy with it. but I noticed that compared to other distros I was using before the boot time is slow.
here it is.

systemd-analyze
Startup finished in 3.707s (firmware) + 5.715s (loader) + 2.873s (kernel) + 28.033s (userspace) = 40.329s

Usually my boot up time is less than 10s (tried on Manjaro(kde, xfce, cinnamon, gnome), Ubuntu(mate, gnome), mint (kde, cinnamon)).
Here is detailed output of the previous command

systemd-analyze blame
         15.106s nmbd.service
         11.775s NetworkManager-wait-online.service
          3.012s iio-sensor-proxy.service
           283ms dev-sda4.device
           269ms upower.service
           197ms systemd-fsck@dev-disk-by\x2duuid-94D1\x2d4AFB.service
           182ms media-sevadah-SharedData.mount
           149ms networking.service
           140ms quota.service
           132ms NetworkManager.service
           129ms systemd-timesyncd.service
           123ms keyboard-setup.service
           105ms ModemManager.service
           102ms accounts-daemon.service
            98ms systemd-fsck@dev-disk-by\x2duuid-0535dbbe\x2d317b\x2d40f3\x2db71f\x2dccb37b78705a.service
            93ms smbd.service
            92ms systemd-modules-load.service
            92ms systemd-journald.service
            85ms systemd-udevd.service
            81ms virtualbox.service
            68ms systemd-udev-trigger.service
            55ms bluetooth.service
            54ms lm-sensors.service

Seems, that processes nmbd.service & NetworkManager-wait-online.service take around 20s and are the most time consuming ones.
I did a little research in the web and as far as I understood nmbd.service is related to Samba, which I dont use. Also I am running Netrunner on the laptop, so I guess I dont need
ModemManager.service. Am I right?

I use my laptop at home and on the lab at the university, wher I do connect it to a network printer via AppSocket / HPLaserjet option in the Printers settings. So I am not sure do I need Samba for this?
How safe it would be disabling/removing Samba? Would it affect other utilities in the system?
If it is safe, can you please help me to properly disable/remove it. (Sure I can do it via Synaptic package manager, but I am not sure is it right thing to do).

Also on the login I see these massages on the screen, I guess it is also related to the network management (sorry for the low quality picture)

Thank you in advance,
Best regards,
svooo

P.S. thank for the great distro, I hope will finally stop distro hopping and settle with Netrunner :slight_smile:

P.P.S. as I am new I am not sure if this is the correct place to post the tread, please feel free to change it to appropriate section. :slight_smile:

[quote]I use my laptop at home and on the lab at the university, wher I do connect it to a network printer via AppSocket / HPLaserjet option in the Printers settings. So I am not sure do I need Samba for this?
[/quote]
Probably not.

I would suggest first disabling it only to see if it improves bootup times. If you need it (for the university work) you can just start it with one simple command line.
It will affect utilities such as samba shares in dolphin or systemsettings. But if you don’t use it you won’t notice it.
It has no effect on the samba client.
To disable just type in

systemctl disable nmbd it should ask you for your user password and then disable the service so it won’t start next bootup.
To stop the service directly (no effect on next boot but only current session) you can use

systemctl stop nmbd

The systemctl start nmbd might come in handy if you need a samba server on your laptop again.

[quote]
Also on the login I see these massages on the screen, I guess it is also related to the network management (sorry for the low quality picture)[/quote]
These messages indicate that you are missing the ath10k firmware files. Installing the package firmware-atheros should fix it.

Hi leszek,

thanks for your response. This did the trick.

It saved me around 15s on bootup. Also I masked NetworkManager-wait-online.service and it saved me another 10s. Also I removed iio-sensor-proxy.service as I dont have touchscreen and neither using screen rotation and that saved me another 3s. overall now my laptop boots in less than 10s. :slight_smile:

the package is already installed, I tried to reinstall it but no change, I still have the same messages. :confused:
I guess it is about my wifi card drivers, but it is working, probably I need a newer version of the package?

Yeah might be you need a newer version as the firmware you need is not included as it seems.
However if everything is working fine with the wifi. I would not bother much.

I agree.
Thanks for your support, is there way t mark the thread as solved?

You can just edit the initial thread and edit the title to add [solved] to it :slight_smile:

ok, thanks :smiley: done :wink:

How did you “mask” the NetworkManager-wait-online.service? Mine is also slowing down the boot together with apt-daily.service. Can apt-daily.service also be disabled?

Yes apt-daily.service can be disabled. In fact it is disabled by us (using a config as apt-daily service takes a look at a config before it runs) by default in 17.03

Well, this is a clean install of Netrunner 17.03 and apt-daily was not disabled. I’ve implemented a solution from the debian bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844453 where they use a timer to start the apt-daily later, after boot.

[code]sudo systemctl edit apt-daily.timer

apt-daily timer configuration override

[Timer]
OnBootSec=15min
OnUnitActiveSec=1d
AccuracySec=1h
RandomizedDelaySec=30min[/code]

I’ve also found how to mask the NetworkManager-wait-online.service so boot is a bit faster now, though now the main culprit is this:

7.923s dev-sda2.device 7.218s quota.service

I’ve disabled the quota service, as I don’t need it, but the dev-sda device cannot be “disabled” :wink: I’ve read somewhere that the fsck takes some time to check it and I don’t want to remove the fsck check, so I think I’ve reached the maximum.